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Você encontrara aqui a documentação para varios plugins GLPI <http://glpi-project.org>
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CAPÍTULO 1

Apresentação

Plugins são uma maneira de o GLPI possibilidades sem modificar o código fonte principal. Em um mundo perfeito, os
plugins devem fornecer recursos específicos; enquanto o núcleo pode fornecer recursos que todos (ou quase!) podem
achar úteis.

Alguns dos plugins existentes são muito complexos, outros são muito simples. Alguns podem exigir que leia a do-
cumentação antes de usar, alguns não . . . Alguns podem fornecer possibilidades de configuração, gerenciamento de
direitos de acesso e assim por diante . . . Ou não! Existem tantos plugins já!

Se você está procurando por um recurso que ainda não existe no núcleo do GLPI, de uma olhada no repositório de
plugins. Você pode procurar por um nome de plugin ou funcionalidade, veja quais versões do núcleo são compatíveis
e assim por diante.

O objetivo da presente documentação é centralizar as documentações, mas não podemos fingir que todas as documen-
tações de plugins estão hospedadas aqui.

De qualquer forma, contente GLPI-ing!
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CAPÍTULO 2

Empty

Download Sources
not relevant https://github.com/pluginsGLPI/empty

This plugins does. . . nothing. Really!

This is designed to be a start point for writing plugins, with very minimal defaults usefull scripts, and some advices. If
you’re looking for plugins possibilities, take a look at the example plugin.

2.1 Create a new plugin

An utility script to create a new plugin - plugin.sh is provided. You will call it with a plugin name, a version, an
optionally the path where your want it to be created:

$ ./plugin.sh MyGreatPlugin 0.0.1

The script will sanityze and lowercase the name you provided, copy the templates files into the new directory, and then
make some replacements.

Using the script without destination parameter, it will create you directory plugin, mygreatplugin just beside its own
directory. Otherwise, it would create the new directory in the specified path:

$ ./plugin.sh MyGreatPlugin 0.0.1 /path/to/glpi/plugins/

5
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2.2 Update existing plugin

There is no automated way to update an existing plugin, because there would be too many cases to handle. But don’t
worry, procedure is quite simple ;)

Using empty features is as simple as creating a few files:

• composer.json,

• .travis.yml,

• Robofile.php,

• .gitignore.

If you do not have yet any composer or travis configuration file, you can just copy the ones from empty plugin.
Otherwise; in you composer.json, just add:

{
"minimum-stability": "dev",
"prefer-stable": true

}

And then run composer require glpi-project/tools.

In the travis configuration file, just add the CS call:

script:
- vendor/bin/robo --no-interaction code:cs

In the .gitignore file, add the following:

dist/
vendor/
.gh_token
*.min.*

As for the Robo.li configuration file, note that the one embed in the empty plugin is a bit specific, you’ll have to edit it
in order to get things working. See below for more informations.

Finally, as the tools project will provide you some features, you can remove duplicated tools scripts (files such as
release, extract_template.sh, . . . ) that would be present in your plugin.

2.3 Features

2.3.1 Coding standards

The GLPI PHPCodeSniffer rulesets are provided as vendor/glpi-project/coding-standard/GlpiStandard/.

To check coding standards, just use the Robo.li task code:cs:

$ ./vendor/bin/robo code:cs

Nota: The above command will ignore vendor and run on the current directory.

6 Capítulo 2. Empty
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If you want to adapt ignore list or checked directories, you can just override $csignore and/or $csfiles in the
RoboFile.php of the plugin:

<?php

class RoboFile extends Glpi\Tools\RoboFile
{
protected $csignore = ['/vendor/', '/lib/'];
protected $csfiles = ['./', 'setup.php.tpl']
[...]

}

2.3.2 Automated checks

For convenience; a .travis.yml file is also provided, that is setup to:

• check coding standards,

• run on a bunch on different configuration

You still have to enable travis-ci builds from the website in order to activate automated tests.

Of course, the .travis.yml file can be pimped; you can run unit tests, create/update a database, activate notifications,
and so on. Refer to the Travis-CI documentation to know more.

2.3.3 Minifying CSS and JS

Aviso: Disabled as of 0.1.13, because libs used from Robo are out of date and connot be replaced.

A convenient script, using Robo.li is provided. The RoboFile.php file is an empty class that extends Glpi\Tools\
RoboFile (provided by glpi-project/tools dependency) in which you can set your own stuff.

That way, you can quite easily update the common file and get your own tasks remaining the same.

To get the required libs installed, you’ll have to get composer installed and then run:

$ composer install -o

There are three available targets:

• minify that will minify all CSS and JS files (see below),

• minify:css that will minify all css stylesheets files in the css directory of your plugin, creating a .min.css
version along with the original file,

• minify:js that will minify all javascript files in the js directory of your plugin, creating a .min.js version
along with the original file.

Just choose a target, and run something like:

$ ./vendor/bin/robo minify:css

Nota: Remember compiled files should not be commited on your repository sources. It is a release process to minify
files.

2.3. Features 7
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Also remember to adapt your scripts so they load your minified versions if available, and the original one otherwise :)

As of GLPI 9.2; you do not have to care about loading minified files when using add_css and add_javascript
hooks! You just need to call not minified script; and GLPI will use the minified version if it exists and if not in DEBUG
mode.

2.3.4 Translations

GLPI and its plugins use gettext for internationnalization. Several steps are required before that can work:

1 translatable strings must be extracted from source files, a POT file will be created or updated accordingly, 2 PO files
must be created or updated from the POT file, 3 PO files must be translated, 4 MO files must be compiled from the latest
PO.

In the vendor/bin directory, you’ll find a extract_template.sh script. This is designed to extract translatable
strings from your source code (see first point above).

Once it has been ran, a locale/mygreatplugin.pot file will be created/updated.

For the second and third step, you’ll have to make a choice. You can use gettext tools to update your PO files and
translate them using a dedicated tool, like poedit; or you can use an online translation system like Transifex or Zanata.
GLPI core and many of existing plugins are translated using Transifex right now.

Once you get your updated PO files, you’ll have to compile them to MO files. You can run it manually, the release script
will compile them again anywways; see the compiling MO files section.

2.3.5 Release script

A release script is provided in vendor/bin/plugin-release. This is a «simple» Python script; you should just have
Python installed on your system (this is installed by default on most linux distributions).

Aviso: Note that the release script is only compatible if you use semantic versionning!

Using just the defaults, the script will try to retrieve the latest tag in your git repository, add third party dependencies
and create a Release on the github project:

$ ./vendor/bin/plugin-release
Do you want to build version 1.9.5? [Yes/no] y
Building glpi-order-1.9.5...
Archiving GIT tag 1.9.5
Adding vendor libraries
$ ls dist
glpi-order-1.9.5.tar.bz2 glpi-order-1.9.5.tar.bz2.asc

8 Capítulo 2. Empty
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Requirements

You will need a python interpreter installed as well as the following modules:

• termcolor,

• gitdb,

• github (to check for existing versions in also in drafts, and to create github releases), unless you use the
--nogithub option

If you want to get help on the script, try to run ./vendor/bin/plugin-release -h.

Process

The release process will achieve the following tasks for you:

• check if the version constant is the same as the tag you’ve requested;

• check if the version in the website XML file is the same as the tag you’ve requested;

• check if a release already exists, locally, and remotely (assuming your project is hosted in the pluginsGLPI
organization and the release is public);

• make a git archive of the paths that are not excluded (.git, tools, tests, . . . );

• if any, install composer dependencies;

• if any, compile you MO files;

• if any, compile you CSS stylesheets and your Javascript files (using Robo.li);

• create a release archive with all that; that will be available in the dist directory;

• use GPG to sign the archive.

Nota: The standard release process will not work on your files directly, it will make a copy in the dist/src directory
before. The only exception is the MO compiling option.

In order to check if all is OK before doing real release; create your tag and run ./vendor/bin/plugin-release
-C before pushing your tag. That way, you’ll be able to fix potential issues and re-create your tag locally (remember
published tags should never be removed).

Compiling MO files

The release process will automatically compile every PO file it will found in your locales directory. But you probably
want the sources to contain the latests MO files, for testing purposes. The release script provide the --compile-mo (or
-m) to achieve that:

$ ./vendor/bin/plugin-release --compile-mo

Aviso: The above command will work on your plugins files directly; not on a copy as does other commands.

2.3. Features 9
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Pre-releases

Per default, the release script will work only on existing tags. Any pre-release should have its own tag; but you may
want to create a release archive without any tags in some circumstances.

In order to tell the release script what it should archive, you’ll have to specify several parameters:

• --commit (or -c) giving the commit hash,

• --release (or -r) giving the release version (usually, it will be the next release version),

• --extra (or -e) to specify an extra string (such as alpha, beta, rc1, etc. . . )

As an example with the order plugin:

$ ./vendor/bin/plugin-release --commit 632d515d4ac0 --release 1.9.5 --extra alpha1
$ ls dist
glpi-order-1.9.5-alpha1-20161103-632d515d4a.tar.bz2

Signing releases

Signing releases with a GPG key would permit users to check download integrity before installing. You’ll need a GPG
key publically available to users; the sign option is activated per default, you can deactivate using the --nosign (or
-S) option.

A file containing the signature with the same name as the archive with a .asc extension will be created in the dist
directory.

GitHub release

The release script will create a release on your GitHub repository, as a draft, unless you use --nogithub (or -g) option.

Nota: Unfortunately, I was not able to get the newly created archive uploaded to this new release. . . Maybe that could
be fixed in the future.

In order to use this feature, you will need the github installed; and you will need an access token. Access token is valid
per user, and gives accesss to all his repositories.

You’ll have to go to your github account settings page, in the personnal access token tab. Click on generate new token,
give the description you want, and make sure you’ll check the public_repo box only (no need to check anything else,
you can create several access token if you need).

The token will be displayed only once; store it in the .gh_token file in your plugin directory; and that’s all!

Excluding files

You can create a .ignore-release file at the root of your plugin and list here files and directories you want to
explicitely exclude from the release archive. Write one expression per line

.+\.png
screenshots/

Some files will automatically be excluded:

• .git*,

10 Capítulo 2. Empty
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• .gh_token

• .tx/

• tools/

• tests/

• .atoum.php

• .travis.yml

• .circleci/

• .ignore-release

• composer.lock

• Robofile.php

2.3. Features 11
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CAPÍTULO 3

Exemplo

Download Sources
not relevant https://github.com/pluginsGLPI/example

Um plugin de exemplo. . . Este é designado para mostrar diversas possibilidades que são oferecidas aos plugins pelo
core do GLPI

Como este plugin não faz nada na realidade, não há documentação para isso. Você gostaria de se
referir a: doc: plugins presentation <../ presentation>, plugins developer manual <http://glpi-developer-
documentation.readthedocs.io/en/master/plugins.html> _ ou mesmo: doc: empty plugin <../ empty / index> para co-
meçar.
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CAPÍTULO 4

Centreon

Download Sources
https://github.com/pluginsGLPI/centreon/releases https://github.com/pluginsGLPI/centreon

4.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

4.2 Features

Centreon is a network, system, applicative supervision and monitoring tool. Centreon plugin allows you to see general
information about hosts and their services on your GLPI interface, as long as the items are both in GLPI and Centreon.

You can perform 3 main actions :

• Acknowledge a problem

• Schedule a downtime

• Trigger a host check,

and you can also see the timeline of the host.
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4.3 Installation

• Uncompress the archive

• Move the centreon folder to <GLPI_ROOT>/plugins directory

• Navigate to the Configuration > Plugins page,

• Install and activate the plugin.

4.4 Usage

You need to configure the plugin before using it. To do so, go to the Setup > Plugins > Centreon page. You will need
to fill the following fields :

• Centreon URL : The URL of your Centreon interface, following by the number of the port, and the API version
to use

• Centreon Username : The username of your Centreon account

• Centreon Password : The password of your Centreon account

Then, it will create automatically a new SQL table named glpi_plugin_centreon_hosts. This table will contain
all the hosts that are both in GLPI and Centreon. A new tab is created on the host page, so you can see the information
about the host.
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CAPÍTULO 5

Credit

Download Sources
https://github.com/pluginsGLPI/credit/releases https://github.com/pluginsGLPI/credit

5.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

5.2 Install the plugin

• Go to the marketplace. Download and install the plugin “Credit”.

19
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5.3 Setting up the plugin

5.3.1 Creating a credit type

• From Setup > Dropdowns,

• click on Credits then Credit types.

• Click on add.

• Enter a name representing the type of credit granted
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5.3.2 Add credit to customer entity(ies)

Example : We will create 3 types of credit:

• For a new follow-up

• For a new task

• For a new solution

You can create a single type of credit which will group together the 3, it depends on the management of
each case.

• In Administration > Entities, select the entity that will receive the credits.

• Go to the Credit section

• In the section Add a credit, enter a name for the new credit

• Define the type of credit created earlier

• The start and end dates of the credit

• Activate it,

• Make it available or not in the child entities (note that if you are in the parent entity, it will be accessible to all
entities)

• The quantity of credit sold

• The authorisation to overconsume or not

• Click on add

Here, we’ll do the same for the 3 types of credit (followup, task and solution)

It is therefore possible to enter different values (number of credits, validity, overconsumption, etc.) for each credit:
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5.3.3 Define default values

• In Administration > Entities, select the entity that will receive the credits

• Go to the Credit section

• In the Default options for entity section

• Select the type of credit by action

• Click on Update

Aviso: «Caution Indicating credit types does not allow automatic settlement. It pre-selects the credit but it must
be settled by the technician.

5.4 Counting credits

When a ticket is created, you can choose whether or not to deduct the corresponding credits.

In our example, we have chosen to deduct each action.

• If we are doing a follow-up, we can deduct the credit assigned by default:

• The same for a task:

• And for a solution :

In the Credit section of the ticket you can see a summary of credits spent and remaining
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5.5 Modify a credit on a ticket

5.5.1 Increase or decrease a granted credit

You can modify credits on a ticket if a readjustment is necessary.

• From the ticket in question, go to the credit section

• Select the credit you wish to adjust

• Click on Actions

• Click on Update

• Click on Quantity consumed then add the desired quantity

• Click on Send

Nota:

See how to proceed
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5.5.2 Delete deducted credits

• From the ticket in question, go to the Credit section

• Select the credit you wish to delete

• Click on Actions

• Click on Delete permanently

• Click on Send

Nota:

See how to proceed

Credits will be automatically reallocated in the credit bank

5.6 Including an expired credit

If the credit has expired, it will not be proposed in the list of available credits. You will not be able to deduct it. You
will need to change the end date of the credit to be able to use it again.

5.7 Notification of expired credits

An automatic action is available to notify you when a credit has expired.

• From Setup > Automatic actions, modify the creditexpired action to suit your needs.

• Click on Save

You can of course customise the notification to suit your needs (Setup > Notifications > Notifications > credit expired)
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5.8 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 6

Datainjection

Download Sources
https://github.com/pluginsGLPI/datainjection/releases https://github.com/pluginsGLPI/datainjection

6.1 Requisitos (localmente)

Versão do GLPI PHP mínimo Recomendado
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

6.2 Instalação do plugin

• Vá para o marketplace. Baixe e instale o plugin Data Injection.
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6.3 Gerenciamento de direitos

Uma vez que o plugin tenha sido instalado através do marketplace, você pode configurar os direitos de acordo com o
perfil.

• Do Administração > Perfis, selecione o perfil em questão

• Ir para Injeção de Dados

Para cada perfil de usuário, você pode conceder os seguintes direitos:

• Gerenciamento de modelos: Ler / Atualizar / Criar / Limpar

• Importar arquivo : Ler

6.4 Configuração

Você pode encontrar a configuração do plugin em Ferramentas > Injeção de dados A extensão é apresentada na forma
de um assistente, cada operação é dividida em etapas e é possível retornar à etapa anterior para corrigir uma escolha.

6.4.1 Gerenciando ou usando um modelo

O primeiro passo permite que você escolha a operação a ser realizada, dependendo dos seus direitos.

• Use um modelo existente no menu suspenso

• Gerenciar modelos para:

– Criar um novo modelo

– Modificar um modelo existente

– Excluir um modelo existente

– Use um modelo existente
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6.4.2 Criando um modelo

O primeiro passo é criar um modelo se nenhum existir.

• De Ferramentas > Injeção de dados

• Clique em Modelo

• Clique em Adicionar

Definindo o modelo

Este passo permite que você defina as principais opções para a extensão.

• Nome: o nome que será visível na lista suspensa

• Visibilidade: define se será visível para outros usuários ou não

• Entidade e subentidade: o modelo pode ser visível apenas na entidade de criação (subentidade definida como
não) ou na entidade e todas as subentidades (subentidade definida como sim).

• Comentário: um comentário para o modelo.

• Tipo de dados a ser importado: o tipo de dados presente no arquivo a ser importado. Um arquivo consiste
apenas em dados do mesmo tipo.

• Permitir criação de linhas: informa ao plugin para criar objetos se a linha não corresponder a um elemento
existente no banco de dados.

• Permitir atualizar linhas: informa ao plugin para modificar objetos existentes usando os dados no arquivo.

• Presença do cabeçalho: informa ao plugin se os cabeçalhos presentes no arquivo (localização, tipo de equipa-
mento, modelos, etc.) devem ser criados. A criação também será limitada pelos direitos do usuário do modelo.

• Update existing fields: the extension whether the data in the file can replace fields already filled in.

• Date format: the date format is contained in the CSV file. If the format is incorrect, the date cannot be imported.

• Decimal number format: the format used for the numbers in the CSV file. If the format is incorrect, the numbers
cannot be imported.

After validation of the model, the following fields are added:

• Presence of a header: indicates whether the first line of the CSV file is a header line, so that you can see the
contents of the columns to identify the contents of the columns

• File delimiter: field separator (by default a semicolon)
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File to be injected

• From the File to inject tab, you need to choose a file on your computer with exactly the same structure as the
data already imported.

• Then define the encoding (ISO8859-1 for Windows files, UTF-8 for Linux files. Automatic detection can be
used to determine the encoding, but will slow down file processing. We strongly recommend that you always
work in UTF-8.)

Once the file has been validated, you will be taken to the Mappings tab

Mappings

This stage is essential. It defines, for each column in the file, the corresponding field in the database. The columns are
identified by the content of the header line (presence defined in the previous step) or by their position (starting from 0).
A separator error (in the previous step) will result in an incorrect split. The View file button is used to preview the first
lines of the file and check their content and the interpretation made by the plugin.

For each column, you can choose

• Do not retrieve data from this column (leave the Choose a table option)

• Choose a table: the data type defined in step 2 or the financial information

• Choose a field: which will be populated by the import

• Link field: to indicate that this column will be used to check the existence of the data in the database and to
choose between creating a new object or update. Candidate fields are, for example, the Serial number, the
Name or the Inventory number

Aviso: It is mandatory to define at least 1 linking field. If a field is checked, it must be entered in your csv file
used for importing.

Nota: It is possible to define Comments or Notes as the destination for several columns in the file. Each column
will be added to the field on a different line. This step is particularly important and a wrong choice could damage the
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inventory data. It is therefore advisable to test the import on a test database or to and reserve this function for advanced
users.

6.4.3 Additional information

This step is used to define the fields that can/should be populated by the user when a file is injected. For each field, the
same value will be used for each line of the file and will take precedence over the contents of the file.

• Table: the data type defined in step Matching

• Field: will be populated by the import

• Mandatory information: whether model user input is mandatory or optional

Exemplos de uso:

• Data de compra ao importar uma nota de entrega

• Comments to define a criterion that can be used in the search engine (e.g. IMPORT ON 31/10)

Model validation

From the Validation tab, you can confirm the registration. It is still possible to return to the previous steps to check and
correct certain options.

Aviso: If you are working with a sub-entity, you must select the desired entity before importing.

Nota: Some fields in your CSV file will need to be filled in as Booleans. This is the case, for example, with double-
choice fields, such as: “Ports” (serial/parallel/USB) for printers. Instead of entering Yes | No in your CSV, enter 1 | 0
as appropriate. If these values are not changed, you will see an error in the report indicating that the wrong type of data
has been entered.
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6.5 Usando um modelo

6.5.1 Escolhendo um modelo

• De Ferramentas > Injeção de dados, selecione o modelo que você precisa na lista suspensa.

• Em seguida, digite o caminho para o arquivo CSV a ser injetado.

• Especifique a Codificação do arquivo se você souber. Caso contrário, deixe em Detecção automática.

• Clique em Proceder com a importação

Confirmar antes de importar

Uma janela pop-up irá solicitar que você confirme ou não a importação do arquivo selecionado.

6.6 Importar resultado

A partir desta última etapa, ao clicar no círculo colorido, você pode visualizar um relatório sobre a importação e, em
particular, localizar quaisquer erros.

6.7 Completar a operação

Uma janela pop-up irá perguntar se você deseja ou não confirmar a importação do arquivo selecionado. Assim que a
barra de progresso estiver completa, clique em Concluir.
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6.8 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 7

Escalade

Download Sources
https://github.com/pluginsGLPI/escalade/releases https://github.com/pluginsGLPI/escalade

7.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

7.2 Install the plugin

• Go to the marketplace. Download and install the plugin Escalade.
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7.3 Assign a ticket

Dica: Escalade vs business rules We advise you to use business rules to allocate tickets or escalations. This allows
you to manage more flexibly when changing category, urgency, etc.

Nota: Escalade allows tickets to be escalated only to groups, and not to live users.

When the plugin is activated, a new option is available from the ticket interface :

7.4 Set plugin parameters

• From the plugin, click on the spanner and choose the various options that interest you:
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Action Effect
Remove old assign group on new group assign Deletes or not the existing groups when you assign a new

one
show group assign history visually

(valid only if previous option is set to yes)
Previous groups will be visible when a new
group is escalated

Assign ticket to initial group on solve ticket (valid only if previous option is set to yes) Reassigns tic-
ket to initial group if a group is deleted

Escalation history in tasks Keep or not the history of escalations in the tasks
Remove technician(s) on escalation Technician(s) will be deleted when a new technician is

added to the ticket
Ticket status can be changed after escalation Modify the status of the ticket after the escalation. A “do

not modify” option is also available.
Assign the technical manager on ticket category
change

If a technical manager is declared in an ITIL category,
they will be automatically assigned and will receive a
notification.

Assign the technical group on ticket category change If a technical group is declared for an ITIL category, it
will be automatically assigned and the members of the
group will receive a notification

Clone tickets Possibility of cloning tickets from the helpdesk interface
.. figure:: images/Escalade-4.png

Close cloned tickets at the same time Close all cloned tickets when one of them is closed
Use the technician’s group If a technician is assigned, their group will also be assig-

ned. You can choose to take account of the assignment
when the ticket is created and/or modified. You can also
choose to select the first or last group to which the user
is assigned

Remove requester(s) on escalation Remove requester(s) in the event of an escalation. Please
note that no history is kept, as is the case for assigning a
group

Display delete button
Displays the option of deleting ac-
tors from the ticket (ability to refine
which user/group/supplier by reques-
tor/watcher/technician)

Activate filtering on allocation groups Enables filtering and whether or not escalation to other
groups is possible. See next chapter for more informa-
tion
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7.4.1 Setting up filtering

Filtering allows you to define which group is able to escalate tickets to other groups. For example, we don’t want N1
support to be able to escalate to N3 directly. The escalation to N2 must be mandatory.

• From Administration > Groups, select one of the groups

• In Escalade, add the groups to which this one will be able to escalate tickets.

Aviso: This option can be useful, but it requires all groups to be set up. If, for example, the technician N1 group
can escalate tickets to the technician N2 group, you need to ensure that the technician N2 group can escalate tickets
to the technician N3 group and also to the N1 group, so that a ticket can be escalated if necessary.

Example :

• Joe user is added to group Groupe 1

• Groupe 1 is configured to allow ticket escalation only to Groupe 2

• Joe user can only reassign ticket to Groupe 2 because it’s assign to Groupe 1
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• For other users not assign to Groupe 1, they can’t reassign group to ticket (groups are not proposed
in the list of assignation)

• You can bypass this behavior per user
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7.5 Ticket’s search engine

Plugin add three new search option

• Group concerning by escalation

Ex : get all tickets actually escalated to group Groupe 1

• Number of escalation
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Ex : get all tickets with more than ten escalation

• Number of escalation between two groups

Ex : get all tickets with more than 2 escalations between two groups

7.6 Central page

New dashlet to display ticket solved to close and assign to you group

New dashlet to display not solved ticket where your groups was not actually assign but was in the past

7.7 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 8

Fields

Fields plugin allows to add additional fields on various items GLPI manages: tickets, computers, users, . . .

Download Sources
https://github.com/pluginsGLPI/fields/releases https://github.com/pluginsGLPI/fields

8.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

8.2 Features

• Add containers block on various items,

• Add fields into blocks,

• Display blocks in an existing tab or in their own tab,

• Many fields types available,

• Fields can be flagged as required,

• Manage profiles ACLs per container,

• . . .
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8.3 Install the Plugin

• Uncompress the archive.

• Move the fields directory to the <GLPI_ROOT>/plugins directory

• Navigate to the Configuration > Plugins page,

• Install and activate the plugin.

8.4 Usage

The plugin will create required tables in the database and some files on disk (into <GLPI_ROOT>/files/_plugins/
fields) automatically. Those files and tables will be updated along with the plugin.

Plugin usage is quite simple:

• create a block linked with some items,

• create fields in this block.

You will access the plugin configuration from the Setup > Aditionnal fields menu.

8.4.1 Adding a new block

• Label: the label of the block that will appears on items forms,

• Type: type of display, one of:

– Add tab: will add a new tab on the item form containing the block,

– Insertion in the form: will add the block at the end of the main item form,

– Insertion in the form of a specific tab: will add the block at the end of a specific tab of the item.

• Associated item type: a list of items types on which the block will be added,

• Active: whether the block is active or not.

Nota: You can add only one block of the type Insertion in the form for an associated item type.

Inserting a block in a specific tab is only possible for one item:

46 Capítulo 8. Fields



GLPI plugins Documentation

Once a block have been created, it is possible to change its label or is active flag, but not its type or associated items
list.

Profiles

You can refine profiles access on the block using the Profiles tab from the block. You will be able to choose either No
access, Read or Write for every existing profile.
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8.4.2 Adding a new field

• Label: the label of the block that will appears on items forms,

• Type field type, one of:

– Header: an header label, for visual distinction,

– Text (single line): a single line (input/@type="text") of text,

– Text (multiples lines): a multiline (textarea) text,

– Number: a single number (no text allowed),

– Dropdown: a configurable dropdown list, values are configured from the main GLPI dropdown configura-
tion you can find in Setup > Dropdowns menu,

– Yes/No: a dropdown list with only Yes and No values,

– Date: a standalone date with a date picker,

– Date & time: a date field with a date picker and a time dropdown field (step is configured from GLPI core),

– Users: list of users.

• Active: whether the block is active or not,

• Read only: flag this field as read only,

• Default values: default field values,

• Mandatory field: flag this field as mandatory.

Aviso: Of course, you will need to pay attention playing with the various options. . . For example, if you flag a
field as mandatory and as read only, and if you do not provide a default value, form validation will fail.

Another example: you should not set a text default value for a number field. . . That kind of things ;)

Once fields have been created, you can reorder or edit them from the Fields tab of the block:
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And see what it should look like on a User item for example:
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8.5 Search

All fields that have been added are available in the attached items search forms.

8.6 Simplified Interface

Only blocks attached to tickets and with the type Insertion in the form will be displayed in the simplified interface of
ticket creation. Of course, it will also take care of current profile rights!

8.7 Translations

Novo na versão 1.4.0.

Plugin itself is translated using the transifex services; but you aslo can translate the label values for blocs and fields;
the process is identical on both those ones:

On the block form, choose the Translations tab:

On block creation, a new translation with current language and value set as label will be created; you can add as many
translations as you want.

Dropdown values can be translated using the core’s dropdown configuration.

Aviso: As of GLPI 9.1.1; some issues on the core side prevent dropdown plugin values to be translated; the
possibility has been deactivated in the plugin. It will be enabled again once the core has been fixed.
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8.8 Entities

If you are using entities in your GLPI instance, a block will be displayed only if the entity it is attached to is compatible
with the one of the item it applies to.

When you create or edit a block in multi entities mode, you’ll have to choose if the block will be available in children
entities:

As an example, let’s say our entities have the following structure:

• root

– A

∗ C

– B

The following table will tell you in wich cases the block is displayed or not:

Block entity Recursive block Item entity Block displayed
A Yes or No A Yes
A Yes or No B No
A Yes C Yes
A No C No

8.9 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 9

Criador de Formulário

Download Sources
https://github.com/pluginsGLPI/formcreator/releases https://github.com/pluginsGLPI/formcreator

FormCreator é um plugin que permite a criação de formulários personalizados de fácil acesso.

9.1 Features

• Direct access to forms self-service interface in main menu,

• Highlighting forms in homepages,

• Access to forms controlled: public access, identified user access, restricted access to some profiles,

• Simple and customizable forms,

• Forms organized by categories, entities and languages,

• Questions of any type of presentation: Textareas, lists, LDAP, files, etc,

• Questions organised in sections. Choice of the display order,

• Possibility to display a question based on certain criteria (response to a further question),

• A sharp control on responses from forms: text, numbers, size of fields, email, mandatory fields, regular expres-
sions, etc,

• Creation of one or more tickets from form answers,

• Adding a description per fields, per sections, per forms, entities or languages,

• Formatting the ticket set: answers to questions displayed, tickets templates,

• Preview form created directly in the configuration,

• Translation of forms to serve them in several languages.
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You can take an look to the full changelog from plugin sources.

9.2 Instalar o plugin

• Descompacte o arquivo.

• Mova o diretório formcreator para o diretório <GLPI_ROOT>/plugins

• Navegar à pagina Configuração > Plugins,

• Instalar e ativar o plugin

Aviso: O diretório de plugin deve ter o mesmo nome do plugin:

• Ótimo: glpi/plugins/formcreateor

• Ruim: glpi/plugins/formcreator-master

• Ruim: glpi/plugins/formcreator-0.90-1.3.2

Apenas um diretório deve conter os arquivos de plugin de no diretório de plugins do GLPI. Não renomeie o dire-
tório do plugin para backup, mova-o!

9.3 Service catalog

The service catalog is a replacement for the GLPI’s simplified interface.

It is enabled on a per entity basis and exists in two flavors

• simplified

• extended

To enable it, edit an entity, open the Forms tab and set the field Helpdesk mode to Service catalog simplified or Service
catalog extended. This setting handles inheritance from parent entity to children entities.

Users using the simplified interface will benefit a new interface allowing them to:

• browse forms and FAQ with the unified interface

• follow the process of their requests

• book assets

• view their feeds

Users using the extended interface have a more complete view on their requests.

Forms with Direct access on homepage enabled will appear in the interface. Users may search by browsing the cate-
gories on the left of the screen, and may also search for forms with a natural language search engine.

By default FAQ items in the Knowledge Base also show with forms. The only prerequisite is to associate form categories
to knowledge base categories (in Setup > Dropdowns : Forms > Form categories).

It is possible th have a distinct display of FAQ in Administration > Entities > Forms. When Distinct menu entry is
selected the service catalog shows a new menu entry on the left. FAQ are browsable by category and key words.
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Nota: All entity settings for Formcreator propagate to sub entities by default. The administrator may change the
settings in a sub entities to break inheritance.

9.3.1 Overview

The service catalog shows several counters on the top left corner. Those counters show all requests involving the current
user as a author, requester, observer, assigned or validator.

The requests displayed here are

• tickets created without Formcreator

• tickets generated by forms havung only one target tickets

• form answers when the form has no target ticket

• form answers when the form has several target tickets

The request are spread over 4 counters

• processing

• pending

• to validate

• closed

Nota: New requests are not included in the counters.

9.3.2 RSS feeds

When users are allowed to view RSS feds, the service catalog shows a menu entry on the left to access them. RSS feeds
administration is done in GLPI as usual.

9.3.3 Reservations

Users may book an asset with GLPI’s reservation system, avaialble in the left menu of the service catalog.

9.4 Configuração de formulários

9.4.1 Criador de Formulário

Nota: O direito de criar formulários é habilitado para os perfis que possuem o direito de atualizar entidades no GLPI.
Consulte a documentação do GLPI para saber como configurar esse direito.
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Nota: Os formulários devem ser criados nas entidades onde eles são destinados a estar disponíveis. Um formulário
pode estar disponível em sua entidade e todas as subentidades se o campo Entidades filhas estiver definido como Sim.

1. Navegue até Administração > Formulários.

1. Clique no botão para adicionar um formulário +

Os seguintes campos devem ser preenchidos:

• Nome: Nome do formulário.

• Ativo: Um formulário está inativo por padrão. Você precisa ativá-lo explicitamente quando estiver pronto para
uso.

É recomendado preencher o campo Categoria.

• Na interface simplificada, as categorias permitem organizar os formulários por blocos.

• Se você deseja usar o catálogo de serviços, você deve usar categorias de formulário.

Nota: Formulários de categorias são menus suspensos do plugin. Você pode adicionar categorias de formulários
diretamente ao editar um formulário usando o + ao lado do campo de categoria. Você pode fazer o mesmo em Confi-
guração > Menus suspensos > Categoria de formulário.

• Acesso direto na página inicial: Acesso direto ao formulário a partir da interface simplificada do GLPI.

• Descrição: exibe nas formas da lista.

• Language: by default a form is set to the language of its creator. The form will be available only to users using
the same language as the form. Choose All languages to make the form available to users without language
restriction.

• Header: displays when the form is displayed.

• Need to be validate: If Yes a list of validators is displayed. This is a list of GLPI users (with the right Validate an
incident or Validate a request (in its profile) on a compatible entity with the form’s entity. The list of validators
is a multiple choice list. If no validator is selected all of them are submitted when the form is being used.

• Default form in service catalog: if Yes the form will display in the service catalog without being filtered by the
current category or keywords.
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When all fields are filled, click on the add button at the bottom of the page.

Nota: Deleting a form is possible only if there are no associated answers. To delete a form, delete all its answers first
from the Form answers tab.

9.4.2 Sections

After clicking on the tab Question the following page displays:

You must create a first section. Sections are intended to organize questions in the form.

It is possible to setup conditions to show the whole section, based on the answers provided to questions located in other
sections of the form.

9.4.3 Questions

Click on the link Add a question in a section of your choice.

The following page displays:
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A question is made of:

• a title: this is the label of the question in the form.

• a type: see list below.

• a section: the section containing the question. You can move a question to an other section with this field.

• a description: it is displayed under the question in the form. Use it as a hint for the requester, telling him which
content is expected.

• a dropdown list Show field to enable a condition

It submits the following choices:

• Always visible: the field is always displays

• Hidden unless: The question is hidden except if answers to other questions matches a condition.

• Displayed unless: The question is displayed except if the answers to other questions matches a condition.

Conditions may be multiple. To add or remove a condition two buttons are available:
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Nota: List of pictograms

• The circle allows you to make a question mandatory

, or optional

• Arrow up and arrow down allow you to reorder questions in a section.

• Clicking on a question allow you to edit it.

• Two stacked squares allows you to duplicate a question or a whole section.

• The recycle bin allows you to delete a question or a whole section.

Questions are organized on a 4 columns array. You can resize width of questions, reorder them using drag and drop
and put up to 4 questions on the same row.

9.4.4 Types of question

There are about twenty types of questions available. Depending on the chosen type, you need to provide additional
information.

Nota:

• Required: Yes/No. When running the form a red star shows next to label of questions requiring an input.

• Default values: its content depends on the type of the question.

• Range Min/Max: Restricts the value to the given range when running the form.

• Additional validation (Regular expression): You may set a custom regex with a regular expression. Use it
when other restriction methods cannot satisfy your needs. Don’t forget to specify the delimiters of the regex.
You may add any modifier after the closing delimiter.
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Actors

This field allows you to choose one or several users:

• in GLPI, available in Administration > Users

• not in GLPI, by typing an email address

Checkboxes (multiple choices)

Add a line per value in Values. Default values may be set in Default values, one per line. If this field is empty, no
checkbox will be ticked.
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Date / Datetime / Time

This field allows to select a date, a datetime or a time from a mini calendar.

Description

This field only displays information. Use it to give more details about a question.

Dropdown

This field allows the user to choose a value among those available in a dropdown from GLPI (in Configuration >
Dropdowns).

9.4. Configuração de formulários 61



GLPI plugins Documentation

Email

The answer to this type of field must be a syntactically valid email address.

File

This field allows the requester to upload a file.

Float

This field must be a float value. Note you may use a regular expression to tighter restrict the answer.

GLPI Object

This field allows you to build a dropdown from a GLPI object among those available in the menus:

• Assets

• Assistance

• Management

• Tools

• Administration
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Hidden field

This field is hidden and allows to retrieve an arbitrary value when generating the target (ticket or change).

Nota: This type of questions never shows on a form.

Hostname

This field is invisible. It allows to get the hostname of the computer used by the requester, assuming the DNS is able
to properly resolve it from its IP address

Integer

This field must be an integer value. Note you may use a regular expression to tighter restrict the answer.

IP Address

This field is hidden and collects the IP address of the form requester. It does not show in the form.

LDAP select

This field allows you to create a dropdown list with objects from a LDAP directory:

Nota: This type of questions cannot be used to fill actors of a target.
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Multiselect (multiple choice)

This field allows you to create a dropdown list with ability to select multiple items. Values are added one per line in
the field Values. You may set default values, one per line in Default values*. If no default value is set then no item will
be selected by default.

Request type

This field is a dropdown with «Incident» or «Request» choices. It can be used to set the request type of a ticket being
generated by the form.

Radio buttons (one choice only)

Add a line per value in Values. A default value may be set in Default value. If this field is empty, no radio will be
selected.
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Select (one choice only)

This field allows you to create a dropdown list and set its items. Items are added one per line in Values. Default value
may be set in Default value. If there is no default, no item is selected by default.

Tags

This is a hidden field to add a tag to the form for future processing.

Nota: This type of field is only available when the plugin Tag is installed and enabled.

Text

This field allows you to input a single line of text.

Text area

This field allows you to input several lines of text.

Urgency

This field allows you to select an urgency defined in GLPI.

9.4.5 Conditions

Conditions are expressions involving questions and sections which are evaluated in order to determine

• if a question is displayed

• if a section is displayed

• if the submit button of a form is displayed

• if a target (see below) must be generated

Available operators in an assertion are:

• equals

• not equals

• less than

• greater than

• less than or equal

• greater than or equal

• is visible

• is not visible

• matches a regular expression

The condition expression can be used with the following rules:
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• Hidden unless: the item is hidden or not generated except when the expression is true

• Displayed unless: the item is displayed or generated except when the expression is true

9.4.6 Access types

Three values are available:

• Public access: Anonymous users may access the form; you may use it in an intranet.

• Private access: Users having a GLPI account may access the form.

• Restricted access: Only users having the specified profiles may access the form.

When a form is set to Public access it is possible to enable a simple captcha. This captcha should prevent spamming
if a form is accessible from internet.

Nota: Captchas are not enabled by default on anonymous forms. Administrators need to enabled them explicitly
depending on how the form may be accessible from an hostile network such Internet.

9.4.7 Targets

There are three types of targets for a form:

• tickets

• changes

• problems

It is possible to generate any number of targets from a single form. Mixing types of targets is also possible.

To create a target click on the link Add a target

The following window is then displayed:
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Choose a target name and type, then validate. The new target is created and is available for tuning.

9.4.8 Preview

This tab allows you to view how the form will be rendered and test it without activating it.

Nota: Submitting answers from the preview will be actually saved, and will generate targets if the form is not confi-
gured with validation.

9.4.9 Form answers

This tab shows all answers saved for the form.

Nota: To delete a form, all its answers must be deleted first. A warning shows at the bottom of the main tab of a form
as a reminder.

9.4.10 Categories

Menu : Setup > Dropdowns : Forms > Form categories

Form categories allow you to arrange your forms list. Forms are displayed when they belong to the selected category
or any sub category. When a form does not have any category, it is displayed when no category is selected or when the
user selects «view all».

You can add or edit categories generally from the Setup menu : Setup > Dropdowns.

You can also add new categories directly from the form page like all GLPI dropdowns.

They are defined by entities and can be translated since GLPI 0.85 like all other dropdowns.

Nota: Dropdowns translation must be enabled on GLPI general configuration page Setup > General, General setup
> Translate dropdowns = Yes

Nota: Categories may be associated to Knowledge base categories. This link is necessary to allow FAQ entries to
show along your forms.
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Configuration

Render
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9.4.11 Questions

After the creation of a form, create fields for the user to fill out.

The name of the questions will appear on the left and the field type selected on the right.

The Description will be under the input field.

Additional options may be displayed depending on the currently selected question type.

If validation of the input is desired, it can be implemented following PHP Regular Expressions.

If you want to show or hide questions depending on the answers of other questions, use the show fields area when editing
a question. In the version 2.5.0 you may use more complex expressions checking for the content of several questions,
and use logic operator OR and AND. The precedence of boolean operators applies, meaning that AND has precedence
over OR.

9.4.12 Translation

In some cases a form should be available in several languages. Choose first in which language a form should be created.
This language should be english (US or UK) or the language that most of target users understand. This is the fallback
language if no alternative is found.

This language is also used as reference in the translation process. Then be sure that the chosen language is readable by
the user who will translate the form.

To translate a form open the tab Form languages, then create all languages you need to provide to users.
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Choose a language added to the form and click it to begin or resume translation, then select the tab Translations. Click
the button New translation and a popup dialog will open and show a string to translate. Type the translation, and click
save or validate with Enter on your keyboard.

If another string must be translated, it will show immediately. If no more string needs to be translated, a message will
show instead.
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When you close the dialog the list of translated strings is refreshed. You can edit a translation by clicking on it, delete
one or several translations with the checkboxes on the left of the list and the Delete button**. You can also filter the
list with the filter input box.

9.5 Targets

Targets are objects generated by FormCreator submission. If a form requires validation, the targets are delayed until
approbation.

Nota: Targets are currently tickets only.

A target ticket defines the ticket generated by the form. You may have several targets per form.

Open the tab Destination and create a target with a name and a type (currently ticket only).
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9.5.1 Target ticket

A target ticket generates a ticket.

The ticket is build from scratch or from a ticket template available in GLPI. You may

• customize the name of the target ticket to distinguish it from possible other targets,

• customize the title and description of the ticket using questions and answers,

• set tne destination entity of the generated ticket,

• set a time to resomve (formerly due date),

• set the type of ticket (request or incident),

• set the associated elements,

• set the category,

• set the urgency,

• set the location,

• assign tags to the ticket if the plugin Tags is available,

• link the generated ticket to other tickets

• define actors of the ticket.

• define conditions to meet to generate the target ticket

Nota: Setting an urgency, a category or a location (specific or from a question) overrides the urgency defined in a
ticket template (if any)
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Destination entity

Many choices are avaialble:

• Current active entity: the entity of the requester who fills a form,

• Default requester’s entity: the default entity defined for the user who fills the form,

• First dynamic requester’s entity (alphabetical): sorts all dynamic entities of the requester alphabetically and
selects the first one,

• Last dynamic requester’s entity (alphabetical): sorts all dynamic entities of the requester alphabetically and
selects the last one,

• The form’s entity: the entity where is located the form being filled by the requester,

• Default entity of the validator: the default entity of the validator who validates the request,

• Specific entity: an entity set by the form’s designer,

• Default entity of a user type question answer: the default entity of a user choosen by the requester in a question.

• From a GLPI object > Entity type question answer: the entity choosen by the requester from a question.

Nota: Default requester’s entity may be not set, then there is a risk to generate tickets in the root entity.

Nota: Default entity of the validator may be not set, then there is a risk to generate tickets in the root entity.

Nota: Dynamic requester’s entity requires user synchronization, then there is a risk to generate tickets in the root
entity.

Ticket template

Sets predefined setings for the ticket from a template. All settings defined in the target ticket will override the values
found in the template.

Request type

Sets the type of the generated ticket

• Default or from a template: value set by GLPI when no type is set, or from a template, if any and if this template
defiines a type

• Specific type: either request or incident,

• Equals to the answer to the question: the value is set from a request type question.
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Associated elements

Sets associated elements to the generated ticket

None : self explanatory, Specific asset: an asset set by the designer of the form, Equals to the answer to a question: an
asset set by the requester, from a question Last valid answer: an asset set by the requester, from the last visible question
eligible for this purpose

Category

Sets the category of the generated ticket

• Category fro template or none: sets the category from a template if any and if this template has a predefined
category. None in all other cases,

• Specific category: a category set by the form’s designer,

• Equals to the answer to a question: a category choosen by the requester,

• lastr valid answer: a category from the last visible question of type category,

Urgency

• Urgency fro template or none: sets the urgency from a template if any and if this template has a predefined
urgency. None in all other cases,

• Specific urgency: an urgency set by the form’s designer

• Equals to the answer to a question: a category choosen by the requester,

Location

• Location from template or none: sets the location from a template if any and if this template has a predefined
location. None in all other cases,

• Specific location: a location set by the form’s designer

• Equals to the answer to a question: a category choosen by the requester,

Condition to show the target

The form’s designer may restrict creation of the ticket depending on conditions.

9.5.2 Target change

A target change generates a change
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The change is built from scratch. You may

• customize the title, description, imapct, control list, deployment path, backup plan and checklist fields using
questions and answers,

• set the urgency from a value or a question

• choose the entity of the change among many policies

• set the time to resolve

• define the actors of the change

• set the category of the change

• define conditions to meet to generate the target ticket

9.5.3 Target description templating

Target ticket and target change both have description template. By default the template uses the tag ##FULLFORM##.
This tag is a default template where all questions and sections are displayed in the same order as the form.

Each question has 2 tags

• ##question_x## which is replaced by the label of the question. X is the ID of the question.

• ##answer_x## which is replaced by the answer to a question. X is the ID of the matching question.

Questions of type dropdown support more complex expression like ##answer_x.name##. x still means the ID of a
question. the word after the dot is the name of a property available in the search options of the itemtype of the dropdown
question.

As an example, consider a dropdown question which shows locations. The itemtype set by the form designer is «Loca-
tion». The designer can render in the target many fields of the location selected by the requester, such address, postcode,
state, building, and many other data. To find them, the admin may rely on the list available in the search filters for a
location.

9.5. Targets 75

http://creativecommons.org/licenses/by-nc-nd/4.0/


GLPI plugins Documentation

9.6 Issues lifecycle

9.6.1 Abstract

The service catalog relies mostly on a list of issues (or assitance request). Issues are created and maintained upon events
related to tickets and form answers.

When a ticket is created from GLPI, then a new issue is created in the database. When this ticket is being updated, the
issue is updated to reflect all relevant changes.

Form answers are created when a requester fills a form and submits it. When a form answer is created a new issue is
created as well. As a form answer may or may not trigger the creation of tickets, issues behave differently depending
on this quantity of generated tickets.

9.6.2 Ticket created from GLPI

When a ticket is created from GLPI, the issue reflects most useful information from this ticket.

9.6.3 Form answer without any generated ticket

When a form answer did not generate a ticket, or when the form answer generating tickets is waiting for validation,
then the issue reflects the form answer.

9.6.4 Form answer with a single generated ticket

When a form answer trigered the creation of one and only one ticket, then the issue reflects this ticket. This is also true
when the approval of a form answer triggers the creation of a single ticket.

9.6.5 Form answer with several generated tickets

When a form answer generated several tickets, then the issue reflects a list of those tickets. Each ticket is viewable by
the requester, if he is granted to view it.

9.6.6 Status

Computation of status

Issues follow the lifecycle of tickets or form answers, depending on which object it reflects.

When an issue reflects a single ticket, its status takes into account the validation status of a ticket, if any. The validation
status of the ticket takes precedence when the ticket is not solved and waiting for approval or has been refused. For all
other cases, the issue shows the regular ticket status.

You may refer to the following table to have a quick view of how the status is computed:
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Validation Status
NONE WAITING REFUSED ACCEPTED

Ticket
Status

INCOMING T V V T
ASSIGNED T V V T
PLANNED T V V T
WAITING T V V T
SOLVED T T T T
CLOSED T T T T

• T = status picked from Ticket

• V = status picked from Validation

When an issue reflects several tickets then the status of each ticket is computed from the above description, and the least
advanced status is used. If an issue reflects 3 tickets having statuses Waiting, Resolved and Closed, then the choosen
status is Waiting. This means that an issue is closed oly when all its tickets are closed.

searching issues by status

The search engine shows many statuses. Some are shortcuts to search several statuses at once, like tickets, some are
specific to the statuses of form answers.

• new: new issues

• processing (assigned): processing issues

• processing (planned): planned issues

• waiting: issues waiting for information from requester or waiting for validation by a valdiator

• solved: issues solved or refused by a validator

• closed: issues closed or accepted by a validator (this happens when no ticket has been generated after validation)

• not solved: all statuses but solved or closed

• not closed: all statuses but closed

• solved + closed: issues solved or closed

• all: any status

• accepted: issues accepted by a validator

• refused: isses refused by a validator

•
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9.7 Exporting and importing forms

9.7.1 Abstract

Formcreator allows exporting and importing forms between instances of GLPI.

This feature is designed to let administrators develop forms on a testing environment and copy them on a production
environment.

When a form is being imported the plugin searches for a matchng form in the database. This is done with the help of
a random identifier created when a new form is instanciated. Each sub object (sections, questions, conditions, targets)
also have a random identifier. This helps the plugin to find a matching item and update it if necessary. Thanks to this
mechanism Formcreator is able to update a form when it is imported more than once.

9.7.2 Limitations

A form may contain relations to objects of GLPI itself (mostly users, groups, categories, entities). There is currently no
reliable way to maintain relations between forms and GLPI’s objects or assets accross instances. It is therefore highly
recommended to develop forms on a testing environemnt with a reasonably recent copy of the production database.

The export / import feature does not support importing forms accros different versions of Formcreator. The version
2.10 shows a warning if it detects a attempt of importing forms from a previous version. In version 2.11 such imports
are not allowed.

9.7.3 Exporting forms

1. Navigate to Administration > Forms

2. Use massive actions to export one or more forms. Clicking on the Post button will start the download of a JSON
formated file. This file contains all forms selected for the export.
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9.7.4 Importing forms

1. Navigate to Administration > Forms

2. Use the toolbar to import forms.

3. Select one or more JSON files created with the same version of Formcreator and validate.

1. Depending on the complexity and the quantity of forms the process may be slow. Please be patient.

2. Carefully check the messages when the import completes. You may get warnings and errors.
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9.7.5 Import behavior

Entities

When Formcreator imports a form, it checks that the entity of the form exists and the user has right to update entities.
If not, the form is ignored and trigger a warning.

Form categories

Form categories are created if they don’t exist yet.

Users and groups

The users and groups found in target actors must exist. If not, the import of the form will stop with an error, leading to
an incomplete form. Other forms will be imported.
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CAPÍTULO 10

Objeto genérico

Download Sources
https://github.com/pluginsGLPI/genericobject/releases https://github.com/pluginsGLPI/genericobject

10.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

10.2 Funcionalidades

Este plugin permite que você adicione novos tipos de objetos de inventário, integrados à estrutura GLPI.

Oferece suporte as seguintes funções do GLPI:

• gerenciamento de entidades e subentidades;

• pesquisa;

• modelos;

• histórico;

• integração com o helpdesk;

• Integração de plugin de injeção de arquivo CSV;
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• Integração de plugins de desinstalação de itens;

• integração de plugins de gestão de pedidos.

10.3 Exemplos de uso

Objetivo: Gerenciar sua frota de automóveis como o resto de seus ativos de TI.

• Crie um novo tipo de objeto de inventário carro.

• Adicione os campos precisos para um carro, como: nome, número de série, número de inventário, tipo, modelo,
cor, estado, etc.

• Descrever o comportamento de um carro: visível na subentidade, manter o histórico, etc.

• Ajuste os direitos nos carros.

• Ative o objeto carros.

• Organize a sua coleção de carros no GLPI.

10.4 Instalar o plugin

• Descompacte o arquivo.

• Mova o diretório genericobjeto para o diretório <GLPI_ROOT>/plugins

• Navegue até a página *Configuração > Plugins

• Instalar e ativar o plugin

10.5 Uso

10.5.1 Criar um novo tipo de objeto

Este é o primeiro passo.

• Clique no botão * + * no formulário de configuração do plugin.

• Criar um novo tipo de objeto de inventário:

– Nome: obrigatório, minúsculo, e deve ser composto de letras apenas;

– etiqueta: por padrão, o mesmo que o nome

• Validar.

• Ativar o novo tipo de item para usá-lo.

Exemplo: Criar um novo tipo de objeto de inventário carro.
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10.5.2 Editar etiquetas

Para cada tipo, um arquivo de idioma está disponível em <GLPI_ROOT>/files/_plugins/genericobject/
locales/itemtype/

O plugin cria:

• um arquivo de idioma para o idioma atual

• um arquivo de idioma para o idioma padrão do GLPI

Nota: Se os idiomas atuais e o padrão forem os mesmos, apenas um arquivo é criado.

Para alterar a etiqueta do itemtype, para o idioma inglês, edite o arquivo:

<?php
// <GLPI_ROOT>/files/_plugins/genericobject/locales/<itemtype>/<itemtype>.en_GB.php
$LANG['genericobject']['<itemtype>'][1] = "<type's label>";

You can also define labels globally in <GLPI_ROOT>/files/_plugins/genericobject/locales/fields.
<lang>.php files:

<?php
// <GLPI_ROOT>/files/_plugins/genericobject/locales/<itemtype>/<itemtype>.en_GB.php
$LANG['genericobject']['fields']['<itemtype>'] = "<type's label>";

10.5.3 Comportamento de configuração

Exemplo: Descreva o comportamento de um carro: visível na subentidade, manter o histórico, etc.

O novo tipo vai ser gerenciado da mesma maneira que os tipos comuns do GLPI (computador, monitor, dispositivo de
rede, etc.)

Nota: Todos os objetos são pelo menos atribuídos a uma entidade

The Behaviour tab allows you to define:

• child-entities: allows the type to be recursive;

• Helpdesk: allows an object to be associated to a ticket;

• Lixeira: Use a funcionalidade de lixeira do GLPI;

• Anotações: use a funcionalidade de anotações do GLPI;

• Histórico: Permite histórico para este tipo;

• Modelos: permite a gestão de modelos;

• Documentos: permite que documentos sejam anexados a um objeto deste tipo;

• Loans: allows objects to be loaned;

• Contracts: link an object to one or more contracts;

• Network connections: allow ports to be used and management for this type;

• CSV file injection plugin: allows this type to be available for use in the plugin;
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• Item uninstallation plugin: allows this type to be uninstalled;

• Order management plugin: allows this type to be linked to an order;

10.5.4 Adicionar campos

Example: Add the accurate fields for a car, like: name, serial number, inventory number, type, model, color, state,
etc.

Navigate to the Fields tab.

The plugin comes with several ready to use fields:

• Nome

• Tipo

• Modelo

• Número de série

• Número de inventário

• Usuário do item

• Grupo

• Situação

• Comentários

• Anotações

• Localização

• Outro

• Fabricante

• URL

• Data de criação

• Data de vencimento

• Categoria

• Visível no Helpdesk

• Técnico responsável pelo hardware

• Domínio

• Contato

• Número de contato

Nota: Using some behaviour will automatically add some fields to the object:

• network connection => location

• empréstimos => localização

• helpdesk => é visível no Helpdesk

• anotações => bloco de anotações
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Helpdesk integration

To use an object in the helpdesk, use following setup:

• In Behaviour tab : use helpdesk must be set to Yes.

• if the User field is defined, it allows item to be visible in the My Items list (as item whose owner is the user).

• if the Group field is defined, it allows item to be visible in the My Items list too (as item belonging to a group in
which the user belongs to).

• if Helpdesk visible field is set and if the value is set to No in the object, then the object won’t be visible at all in
the helpdesk.

10.5.5 Add new fields

Nota: New fields will be available for all object’s types.

• Create a new file named <GLPI_ROOT>/files/_plugins/genericobject/fields/<type>.constant.
php

For example, for a car type the constant file will be <GLPI_ROOT>/files/_plugins/genericobject/fields/
car.constant.php.

Please note that the file’s first line must be the following, otherwise the new fields won’t appear in the list:

<?php
global $GO_FIELDS, $LANG;

• Add the new fields definitions.

10.5.6 Add a simple dropdown field

<?php
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['name'] = $LANG['genericobject
→˓']["<type's name>"][2];
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['field'] = 'color';
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['input_type'] = 'dropdown';

Nota: The language variable must be defined in the language file (see explaination above).

• Add a dropdown field that is assigned to an entity:

<?php
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['name'] = $LANG['genericobject
→˓']["<type's name>"][2];
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['field'] = 'color';
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['input_type'] = 'dropdown';
//Does the dropdown take care of entities ? (true/false)
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['entities_id'] = true;
//Can values be recursive ? (true/false, only taking in account if entities_id is set to␣

(continues on next page)
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→˓true)
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['is_recursive'] = true;

10.5.7 Add a tree dropdown field

<?php
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['name'] = $LANG['genericobject
→˓']["<type's name>"][2];
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['field'] = 'color';
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['input_type'] = 'dropdown';
//Is it a tree-dropdown, or a simple one ? (true/false)
$GO_FIELDS['plugin_genericobject_mytypecolors_id']['is_tree'] = true;

Nota: You can use at the same time the following parameters : entities_id, is_recursive, is_tree.

10.5.8 Add a dropdown field that is based on a GLPI-core object (user, location. . . )

<?php
$GO_FIELDS['users_id_passengers_id']['name'] = 'Passenger';
$GO_FIELDS['users_id_passengers_id']['input_type'] = 'dropdown';

Nota: Name between brackets ([]) MUST begin with users_id in order to be recognized as a field based on GLPI
users” list.

See file <GLPI_ROOT>/files/_plugins/genericobject/fields/field.constant.php to get a complete list
of available fields.

10.5.9 Add a global dropdown

A global dropdown can be used in all itemtypes. A good example would be :

<?php
$GO_FIELDS['categories_id']['name'] = $LANG['common'][36];
$GO_FIELDS['categories_id']['input_type'] = 'dropdown';
$GO_FIELDS['categories_id']['dropdown_type'] = 'global';

A specific category table will be created for each itemtype. The table name and field name will the computed this way:

• table : glpi_plugin_genericobject_<itemtypename>_category

• field name : plugin_genericobject_<itemtype>categories_id
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10.5.10 Add an integer field

<?php
$GO_FIELDS['testinteger']['name'] = 'testinteger';
$GO_FIELDS['testinteger']['input_type'] = 'integer';
$GO_FIELDS['testinteger']['min'] = 10; //not mandatory, by default 0
$GO_FIELDS['testinteger']['max'] = 40; //not mandatory, by default 100
$GO_FIELDS['testinteger']['step'] = 3; //not mandatory, by default 1

10.5.11 Add a text field

<?php
$GO_FIELDS['mytextfield']['name'] = 'My text field';
$GO_FIELDS['mytextfield']['input_type'] = 'text';

Alterado na versão 2.1.2: By adding the following argument, you can tell the plugin that this field can be automatically
generated when using a template:

<?php
$GO_FIELDS['mytextfield']['autoname'] = true;

10.5.12 Add a Yes/No field

<?php
$GO_FIELDS['mybooleanfield']['name'] = 'My boolean field';
$GO_FIELDS['mybooleanfield']['input_type'] = 'bool';

10.5.13 Add a date field

<?php
$GO_FIELDS['creationdate']['name'] = $LANG['genericobject']['fields'][30];
$GO_FIELDS['creationdate']['input_type'] = 'date';

10.5.14 Add a date & time field

<?php
$GO_FIELDS['creationdate']['name'] = $LANG['genericobject']['fields'][30];
$GO_FIELDS['creationdate']['input_type'] = 'datetime';

Nota: If you don’t want a field to be modified using massive actions, add the following line to its definition:

<?php
$GO_FIELDS['myfield']['massiveaction'] = false;
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10.6 Add global fields

To make your fields accessible to all itemtypes:

• Create a file named <GLPI_ROOT>/files/_plugins/genericobject/fields/field.constant.php

• Put your definitions in this file.

10.7 Setup Rights

You can define access rights for each object’s type, for each profile. Available options are:

• right on the type: no access, read, write.

• right to associate this type of object to tickets: yes, no.

To associate the rights you can either:

• Use the Rights tab in the itemtype form.

• Navigate to Administration > Profiles and administer the rights for each profile.

10.8 Use the new field

Activate the new type, it’s now ready to be used.

The new type is available for users in the Plugins > Objects management menu.

10.9 Use case of Generic Object as a CMMS

10.9.1 Purpose of this documentation

Showing a complete usage of Generic Object as a CMMS (Computerized Maintenance Management System) in bio-
medical environment.

At the end of this use case, you will have :

• a dedicated Biomed entity (under Root entity)

• containing Biomedical objects (in Assets menu)

• with built-in and user-defined fields

• manages by users with Admin_biomed profile
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10.9.2 Steps

Following steps assume you have a Super-Admin authorization :

• Installing Generic Object on GLPI (validated with genericobject >= 0.85-1.0 and GLPI >= 0.90)

• Generic Object configuration

• GLPI configuration

• Start using Generic Object and GLPI

10.9.3 Installing Generic Object on GLPI

See Instalar o plugin section.

10.9.4 Generic Object configuration

Create your type of object

See Criar um novo tipo de objeto section and use biomedical as internal identifier. Label will be set automatically to
Biomedical (with an uppercase B).

After a logoff/login, you will see Biomedical menu in Assets.

Define Biomedical’s new fields

These fields will be usable only by Biomedical’s objects :

• Create a new file named : <GLPI_ROOT>/files/_plugins/genericobject/fields/biomedical.
constant.php

• Add following content :

<?php
global $GO_FIELDS, $LANG;

// CODE CNEH
$GO_FIELDS['plugin_genericobject_cnehcodes_id']['name'] = $LANG['genericobject'][
→˓'PluginGenericobjectBiomedical'][1];
$GO_FIELDS['plugin_genericobject_cnehcodes_id']['field'] = 'cnehcode';
$GO_FIELDS['plugin_genericobject_cnehcodes_id']['input_type'] = 'dropdown';

// REFORME (yes or no)
$GO_FIELDS['reformed']['name'] = $LANG['genericobject'][
→˓'PluginGenericobjectBiomedical'][2];
$GO_FIELDS['reformed']['input_type'] = 'bool';

// CLASSE CE (3 choix possibles 1,2a ou 2b)
$GO_FIELDS['plugin_genericobject_classeces_id']['name'] = $LANG['genericobject'][
→˓'PluginGenericobjectBiomedical'][3];
$GO_FIELDS['plugin_genericobject_classeces_id']['field'] = 'classce';
$GO_FIELDS['plugin_genericobject_classeces_id']['input_type'] = 'dropdown';

(continues on next page)
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// UF (Unité Fonctionnelle)
$GO_FIELDS['plugin_genericobject_ufs_id']['name'] = $LANG['genericobject'][
→˓'PluginGenericobjectBiomedical'][4];
$GO_FIELDS['plugin_genericobject_ufs_id']['field'] = 'uf';
$GO_FIELDS['plugin_genericobject_ufs_id']['input_type'] = 'dropdown';

// PRESTATAIRE BIOMED
$GO_FIELDS['plugin_genericobject_prestataires_id']['name'] = $LANG['genericobject
→˓']['PluginGenericobjectBiomedical'][5];
$GO_FIELDS['plugin_genericobject_prestataires_id']['field'] = 'prestataire biomed';
$GO_FIELDS['plugin_genericobject_prestataires_id']['input_type'] = 'dropdown';

// TYPE D'EQUIPEMENT BIOMED
$GO_FIELDS['plugin_genericobject_typedequipementbiomeds_id']['name'] = $LANG[
→˓'genericobject']['PluginGenericobjectBiomedical'][6];
$GO_FIELDS['plugin_genericobject_typedequipementbiomeds_id']['field'] = "type d
→˓'equipement biomed";
$GO_FIELDS['plugin_genericobject_typedequipementbiomeds_id']['input_type'] = 'dropdown';

// Criticite
$GO_FIELDS['plugin_genericobject_criticites_id']['name'] = $LANG['genericobject'][
→˓'PluginGenericobjectBiomedical'][7];
$GO_FIELDS['plugin_genericobject_criticites_id']['field'] = 'criticite';
$GO_FIELDS['plugin_genericobject_criticites_id']['input_type'] = 'dropdown';

// Numéro marquage CE
$GO_FIELDS['plugin_genericobject_marquageces_id']['name'] = $LANG['genericobject'][
→˓'PluginGenericobjectBiomedical'][8];
$GO_FIELDS['plugin_genericobject_marquageces_id']['field'] = 'marquagece';
$GO_FIELDS['plugin_genericobject_marquageces_id']['input_type'] = 'dropdown';

// Classe électrique
$GO_FIELDS['plugin_genericobject_classeelecs_id']['name'] = $LANG['genericobject'][
→˓'PluginGenericobjectBiomedical'][9];
$GO_FIELDS['plugin_genericobject_classeelecs_id']['field'] = 'classeelec';
$GO_FIELDS['plugin_genericobject_classeelecs_id']['input_type'] = 'dropdown';
?>

Aviso: Trailing s_id is mandatory in [plugin_genericobject_field*s_id*] because the GLPI framework
requires foreign key fields to end with s_id. In database, glpi_plugin_genericobject_fields is table name
and id, its foreign key. See GLPI developer documentation.
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Define fields labels

See Editar etiquetas section.

• Edit your locales file, for example : <GLPI_ROOT>/files/_plugins/genericobject/locales/
biomedical/biomedical.fr_FR.php

• Adicione o conteúdo a seguir no final do arquivo:

<?php
// Fields
$LANG['genericobject']['PluginGenericobjectBiomedical'][1]="Code CNEH";
$LANG['genericobject']['PluginGenericobjectBiomedical'][2]="Réformé";
$LANG['genericobject']['PluginGenericobjectBiomedical'][3]="Classe CE";
$LANG['genericobject']['PluginGenericobjectBiomedical'][4]="UF";
$LANG['genericobject']['PluginGenericobjectBiomedical'][5]="Prestataire Biomed";
$LANG['genericobject']['PluginGenericobjectBiomedical'][6]="Type d'équipement biomed";
$LANG['genericobject']['PluginGenericobjectBiomedical'][7]="Criticité";
$LANG['genericobject']['PluginGenericobjectBiomedical'][8]="Marquage CE";
$LANG['genericobject']['PluginGenericobjectBiomedical'][9]="Classe électrique";

Definir comportamentos

No menu «Plugins > Gerenciamento de objetos», na aba Principal, selecione:

• Item in the dustbin

• Histórico

• Informações financeiras e administrativas

• Documentos

• Pesquisa global

• Assistência

• Modelos

• Contratos

• Pesquisa global

This will add ready to use fields to your type of object.

Add fields to your type of object

In Plugins > Objects management menu, on Fields tab, you can now add fields to Biomedical type of object :

• ready to use fields (GLPI’s built-in fields)

• new fields (defined in Define Biomedical’s new fields section)
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10.9.5 GLPI configuration

Define Admin_biomed profile

1. Clonar perfil Administrador

2. Set following rights in Admin_biomed profile :

• Administration > Profiles > Admin_biomed > Assets tab > Unselect all

• Administration > Profiles > Admin_biomed > Assistance tab > Association > Associable items to a ticket
> Biomedical

• Administration > Profiles > Admin_biomed > Management tab > Select all

• Administration > Profiles > Admin_biomed > Objects management tab > Biomedical > Select all

Nota: With these settings, Admin_biomed users only see Biomedical in Assets menu.

Define Biomed entity and authorizations rules

1. Create Biomed entity under Root entity in Administration > Entities

2. Configure authorizations rules to assign Admin_biomed profile to Biomed entity users.

10.9.6 Start using Generic Object and GLPI

As Admin_biomed user, you can create your first object in Assets > Biomedical.

In order to gain time, define values in Setup > Dropdowns > Objects management for new fields.

10.10 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 11

News

Download Sources
https://github.com/pluginsGLPI/news/releases https://github.com/pluginsGLPI/news

11.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

11.2 Features

This plugin allows to display alerts messages on GLPI homepage and / or login page.

• Create alert with rich text as for notes.

• Choice of begin/end publication date.

• Manage alerts by entity.

• Target : display alerts by profile / group / user.
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11.3 Install the Plugin

• Uncompress the archive.

• Move the news directory to the <GLPI_ROOT>/plugins directory

• Navigate to the Configuration > Plugins page,

• Install and activate the plugin.

11.4 Usage

The plugin will create required tables in the database automatically. Those tables will be updated along with the plugin.

Plugin usage is quite simple:

• configure alerts

You will access the plugin configuration from the Tools > Alerts.

11.5 Create alerts

• Name : display as talert title

• Active : is active or not

• Description : content of alert

• Visibility start / end : period of Visibility

• Type : type of alert (General, Information, Warning, Problem)

• Can close alert : User can close alert ?

• Show on login page : display or not alert on login page

• Show on helpdesk page : display or not alert on helpdesk page

• Sub-entity : display or not on sub-entity
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11.6 Targets

You can define target by type

• Group : for all users of group

• Profil : for all users with profile

• User : for specifi user

11.6. Targets 95



GLPI plugins Documentation

11.7 Display on login page

11.8 Display on helpdesk page

11.9 FAQ

If you have any questions about using the plugin, please consult our FAQ
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OAuth IMAP

Download Sources
https://github.com/pluginsGLPI/oauthimap/releases https://github.com/pluginsGLPI/oauthimap

Nota: Microsoft está gradualmente removendo os protocolos TLS 1.0 e 1.1 para todas as aplicações do Microsoft
365. Para manter seu coletor em execução, você precisa adicionar o plugin OAuth IMAP, que está disponível no
marketplace.

Dica: Os tokens Oauth para o coletor, obtidos durante a autenticação com o Azure pelo plugin OauthIMAP, são tokens
«offline» que delegam autorização a um aplicativo de terceiros (GLPI). Esses tokens fornecem um código de renovação
que será usado pelo aplicativo para renová-los automaticamente sem intervenção do usuário. Portanto, você não será
solicitado a fazer uma nova autenticação após a 1ª solicitação de autorização.

12.1 Requisitos (localmente)

Versão do GLPI PHP mínimo Recomendado
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud
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12.2 Suporta os seguintes serviços de email.

Suporte OAuth IMAP:

• Gmail : https://developers.google.com/gmail/imap/xoauth2-protocol?hl=fr

• Entra: https://learn.microsoft.com/fr-fr/power-platform/admin/connect-gmail-oauth2

12.3 Instalar o plugin

• Vá para o marketplace. Baixe o Oauth IMAP e habilite-o.

• Open the Azure Portal for your tenant

• Na caixa de pesquisa, digite registration

• então selecione Registros de aplicativos

Aqui estão os passos de configuração, incluindo as fases de configuração do lado Entra.

12.4 Registre sua aplicação Entra

12.4.1 Crie o aplicativo

• Clique em Nova inscrição

• Digite o nome desejado, selecione o tipo de conta suportada e insira a URL de redirecionamento (presente na
configuração do plugin da sua interface GLPI: https://XXXXXXXXXXXXXX/marketplace/oauthimap/front/
authorization.callback.php) especificando a opção Web.
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• Então clique em Registrar.

12.4.2 Adicione um segredo

• Na guia Certificados e segredos

• Clique em Segredos do cliente

• Então Novo segredo do cliente

• Digite uma descrição e depois uma data de validade

• Um valor secreto é então gerado. Guarde bem esse valor porque uma vez que você sair desta página, ele não
poderá mais ser recuperado.

• Retorne para a guia Visão geral e copie os seguintes valores e o segredo acima mencionado.
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12.5 Configurar GLPI

• Agora volte para a sua interface GLPI Configuração > Aplicação Aouth IMAP e indique as informações cole-
tadas anteriormente:

• Clique Adicionar

• Agora na guia Autorização Oauth, clique em Criar uma autorização.

• Quando você clicar em Criar autorização, você será redirecionado para a página de login dos serviços da
Microsoft.

• Digite o endereço de e-mail e a senha da conta que será usada para o coletor

• Você também precisará aceitar as permissões necessárias relacionadas ao plugin.
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12.6 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 13

Order

Download Sources
https://github.com/pluginsGLPI/order/releases https://github.com/pluginsGLPI/order

13.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

13.2 Features

This plugin supports the following aspects of order management :

• Definition and management of a catalogue of product references

• Order management (with approval workflow)

• Budgets management

• Management of invoices associated with orders

103

https://github.com/pluginsGLPI/order/releases
https://github.com/pluginsGLPI/order
https://glpi-network.cloud/


GLPI plugins Documentation

13.3 Install the Plugin

• Uncompress the archive.

• Move the order directory to the <GLPI_ROOT>/plugins directory

• Navigate to the Configuration > Plugins page,

• Install and activate the plugin.

13.4 Configuration

You will access the plugin configuration from the Setup > Plugins > Orders managment.

When the plugin is installed and enabled, the following options are available:

• Default VAT: indicates the amount of VAT that will be proposed by default in the plugin

• Use the validation process: indicates whether the full validation circuit should be used, or whether anyone can
validate applications.

• Purchase order generation: indicates if the tab allowing the generation of a purchase order in ODT format is
displayed or not.

• Enable supplier quality: indicates whether the tab for judging supplier satisfaction is displayed once the order is
delivered.

• Display purchase order vendor information: Shows whether or not the tab for storing the reference and vendor
purchase order number is displayed.

• Colour when the estimated delivery date is exceeded: colour of display in the search engine of an undelivered
order for which the estimated delivery date is exceeded
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• Copy order documents when a new item is created : Copy order documents to generated item

• Default heading when adding a document to an order : define default heading

• Author group (Default values) : Define default author

• Recipient group (Default values) : Define defaut Recipient group

• Recipient (Default values) : Define default Recipient

• Do not display expired budgets : yes or no

• Transmit budget change to linked assets : yes or no

• Display account section on order form : yes or no

• Set account section as mandatory on order form : yes or no

• Use free references : yes or no

• Rename documents added in order :yes or no

13.4.1 Automatic actions when delivery Item

Generation does not apply to contracts, cartridges and consumables. In order to activate this feature, change the option
Activate automatic generation to yes and validate. During the generation, the material will be created with some
randomly generated information:

• Default name

• Default Serial Number

• Default inventory number

• If a template is associated with the part number, and in this template the name and serial number are generated,
then the settings defined above for these 2 fields do not apply.

The default status will be set when the material is created. The positioning of the status during the creation of the
material can lead to a date filling of the financial information. See the Entity Inventory tab.
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13.4.2 Order lifecycle

You can define your own status for order lifecycle

13.5 Creation of a reference catalogue

You will access the reference catalogue from the Management > Orders > Products references.

The creation of product references is the prerequisite for order management. Any product to be ordered must be
referenced in the plugin catalog. When creating a product reference, the following fields must be filled in:

• Sub-entities: indicates if the reference will be visible in the current entity only or in the sub-entities as well.

• Name: name of the reference, as it will be displayed when managing an order (required)

• Manufacturer: the manufacturer of the product (not the supplier)

• Type of equipment: indicates what type of equipment we are dealing with

• Type: the type of the product

• Model: the model of the product

• Template: the GLPI template of the product if one already exists.

• comments: additional information on the reference

• Once the reference is created, it is then necessary to indicate from which supplier(s) the product is available, as
well as the price associated with it.

It is also possible to :

• Add related documents
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• View history

13.6 Creating an order

You will access orders from the Management > Orders > Orders.

Once the reference catalogue has been created, it is now possible to add material orders. The fields to be filled in are :

• Sub-entities: indicates if the order is visible in the sub-entities

• Order name

• Order number (required)

• Date of order (required)

• Budget: The budget to which the purchase order is posted.

• Vendor purchase order number: Indicates the internal number for the purchase order at the vendor.

• Payment terms: free field (can contain for example 30 days end of month, 60 days end of month, etc)

• Billing number

• Supplier: the supplier with whom the order is placed. Only the catalogue references from this supplier may be
added to the order.

• Place of delivery of the order: indicates the place where the equipment will be delivered. This option has value
only in the entity in which the order is created.

• Description: description of the order

• Status: Indicates the current status of the purchase order in the release run.

• Estimated delivery date: indicates the indicative date by which the supplier must deliver the order.

It is also possible to :

• Define author and recipient
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13.6.1 Adding articles

In the Details tab, it is now possible to add products to the order.

• Select the type of material to add to the order

• Select product number

• Indicate the quantity to order

• Change the unit price if it is not the price indicated in the product reference.

• Indicate the percentage discount on products

• You can then validate the addition of these products to the order.

Note: it is possible to modify the price and the discount of a set of materials when the order is being edited. To do this,
simply double-click on one of these 2 fields, modify its value and then validate the change.
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13.6.2 Validation workflow

The plugin has a validation workflow that works as follows:

• Creating the order: status In progress

• Request for order release: status Pending approval

• Order confirmed: the order then goes to the status In process of delivery.

• Order completely received: automatic switch to Delivered status

• Cancelled purchase order: Change to status Cancelled

The definition of the persons having the right to make a validation request, to validate or to cancel an order is done in
the edition of the profiles.

13.6.3 Receiving the order

Once the order has been confirmed, the equipment can begin to be received. To do this, you must go to the Receiving
Equipment(s) tab. Each product is identified by a line with the following information:

• Product reference

• Number of equipment(s) received

• Number of material(s) related to inventory items in GLPI

• Unit price of the product (excl. VAT)

• Unit price of the product (incl. VAT)

• Price per unit awarded (excl. VAT)

By clicking on the + icon on the left of the line, it is possible to access the details of the products ordered.
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13.6.4 Receiving material

It is possible to receive the material that has been ordered, from the moment the order is validated. You have to go
to the tab Reception of material(s). One line is displayed for each product reference ordered. This line contains the
following information:

• Product reference

• Received equipment(s): indicates the number of equipment received out of the total number of equipment ordered
for this product.

• Related equipment(s): number of goods received related to inventory items in GLPI

• Price per unit (excl. VAT)

• Unit price (incl. VAT)

• Price per unit awarded (excl. VAT)

In order to proceed to the reception of products, just click on the + icon on the left of the line.

There are 2 ways to receive material :

• Reception of materials selected from the list of products ordered but not yet received

• Receipt of materials in bulk: in this case we will indicate how many products are received (without first selecting
from the list).

In both cases, it is necessary to return the delivery note associated with the reception of the material. Alternatively, a
status of the received objects can be indicated (e.g. Conforming, Non-conforming, etc). Once received, it is possible
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to :

• Generate a material in GLPI from the received product

• Link the product received to existing GLPI equipment

13.6.5 Generate the material

In order to generate materials from received products, simply select from the list those for which this operation is to be
performed. Then select the Generate associated material option. A screen will appear. Each line represents a received
product, and the following information must be given:

• Name of the material generated in GLPI

• Serial code

• Asset number

Note:

• If there is a template associated with the reference of the generated product, and if the latter is created in the
same entity as the reference, then the inventory object in GLPI will be created from this template.

• The financial information of the order will be carried in the newly created inventory object.
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13.6.6 Link to an inventory item

It is possible not to generate a received product, but to link it to material already present in GLPI. To do this, you must
select the option Link to an existing material. A drop-down list will appear and will present all the materials present
in GLPI which :

• Are in the entity of the order (or in a sub-entity if the order is visible in the sub-entities)

• With the same type of equipment

• With the same type of equipment

• Identical

Once linked to a product, the material in GLPI will receive the financial information from the order.

13.7 Rights management

The plugin rights management allows to define, by profile, if the user has the right to :

• Manage commands

• Manage product references

• Manage invoices
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• Confirm an order

• Cancel an order

• Modify a validated order

13.8 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 14

PDF

14.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud.

14.2 Install the plugin

• Go to the marketplace. Download and install the plugin PDF
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14.3 Set up the plugin

• From Setup > General > Print to pdf, select :

– your preferred currency

– Any text that will be displayed on the PDF.

14.4 Using the plugin

Nota: Printing a contract and its related elements

• From Management > Contracts, select the contract you require

• From the Print pdf tab

• Click on Print
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SCCM

Download Sources
https://github.com/pluginsGLPI/sccm/releases https://github.com/pluginsGLPI/sccm

15.1 Requirements for latest version

This plugin requires :

• PHP 7.2 or higher

• GLPI >= 9.4

• FusionInventory plugin for GLPI

• SCCM >= 1802

• PHP curl_init and sqlsrv_connect

• Microsoft System Center Configuration Manager

• Microsoft Drivers for PHP for Microsoft SQL Server

Nota: This plugin is available without a GLPI-Network subscription. It is not available in Cloud
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15.2 Features

Plugin to synchronize computers from SCCM (version 1802) to GLPI (version 9.3 and 9.4). It uses the «FusionInven-
tory for GLPI» plugin and the power of its internal engine.

15.3 Workflow

• This plugin add two automatic actions : «SCCMCollect» et «SCCMPush»

• The automatic action «SCCMCollect» queries the SCCM server with MsSQL queries.

• This same action builds an XML foreach computer (in FusionInventory format).

• The automatic action «SCCMPush» injects XML files into GLPI over HTTP(s) (via cURL and FusionInventory)
to display computer in GLPI.

15.4 Schematic diagram
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15.5 Collected data

Depending on data availability in the SCCM server, foreach computer we collect:

• Computer: name, last connected user, UUID, user login, domain, comments, serial

• Operating system: name, architecture, version, service pack

• BIOS information: tag, model, type, manufacturer, serial, install date, version

• CPU: description (or name), manufacturer, frequency, type (arch), nb core, nb threads

• Softwares: name, version, editor, install date

• Memory (RAM): capacity, decription, frequency, type, bus, serial

• Graphical card: name, chipset, memory

• Sound card: name, manufacturer

• Network card: name, MAC address, IP address (v4, v6)

• Disk part: name, mount type, total size

15.6 Automatic actions
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15.6.1 SCCMCollect

Action to collect data from SCCM to XML files.

15.6.2 SCCMPush

Action to push XML file to FusionInventory plugin
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Treeview

Download Sources
https://github.com/pluginsGLPI/treeview/releases https://github.com/pluginsGLPI/treeview

16.1 Requirements for latest version

16.2 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

16.3 Features

This plugin allows you to browse through your inventory via a tree view in a panel located on the left side of the screen.

You can browse the tree of your site to see the equipment.
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16.4 Install the Plugin

• Uncompress the archive.

• Move the tag directory to the <GLPI_ROOT>/plugins directory

• Navigate to the Configuration > Plugins page,

• Install and activate the plugin.

16.5 Usage

The plugin will create required tables in the database automatically. Those tables will be updated along with the plugin.

Plugin configuration is quite simple:

You will access the create form from the Setup > Plugins > treeview.

• Target for all node : on clic on node, redirect to new window

• Nodes can be highlighted : highlight selcted node or not

• Tree is drawn with lines : display or not

• Tree is drawn with icons : Display or not icon for node

• Only one node within a parent can be expanded at the same time : more tthan one parent node can be expand at
same time

• Item name : name or inventory number or name + inventory number or inventory number + name

• Location name : short name or long name or long name + comment or long name + comment

124 Capítulo 16. Treeview

http://creativecommons.org/licenses/by-nc-nd/4.0/


CAPÍTULO 17

Tag

Download Sources
https://github.com/pluginsGLPI/tag/releases https://github.com/pluginsGLPI/tag

17.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud.

17.2 Install the plugin

• Go to the marketplace. Download and install the plugin “Tag”.
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17.3 Setting up the plugin

• From Setup > Dropdowns

• Click on Tag management

• Then Tags

• Enter a name that will be visible when tags are added

• Enter a description (optional)

• Add a colour

• Associate one or more elements. If nothing is ticked, it will not be visible in any element by default.
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17.3.1 Choose where to find the tag

You can indicate whether the tag should be at the top or bottom of the list.

• From Setup > General > Tag management, specify the tag location.

Bottom :

Top:

17.4 Adding rules

You can add business rules (tickets, computers, etc.) to add tags to particular items.

Example : Assign a VIP tag when a member of the management group writes a ticket.

• Here are the criteria to be implemented from Administration > Rules > Business rules for tickets

• After creating a ticket :

Nota: Tags can, of course, be added manually if they have been set to be visible in the specified item.

17.5 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 18

Uninstall

Download Sources
https://github.com/pluginsGLPI/uninstall/releases https://github.com/pluginsGLPI/uninstall

18.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: This plugin is available without a GLPI-Network subscription. It is also available in Cloud

18.2 Features

This plugin, named «uninstall» or «Item Uninstallation», allows you to remove / replace devices from the inventory by
automating certain actions on the fields.

It allows to manage the different stages of the life cycle of a hardware. It has been designed, among other things, to
handle the following cases:

• scrapping of equipment

• removal from inventory of temporary equipment due to breakdown

• Replacement of equipment under a warranty for example (See: Replacement Equipment Feature)

Once installed, the plugin includes :
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• a rights management directly accessible from Administration -> Profiles (in the Plugins tab -> uninstall),

• a «hardware uninstall» menu in «Configuration»,

• an «uninstall» menu in the user preferences.

18.3 Right managment

It is possible to deny access to the plugin or to allow it by specifying the read or write option on the templates.

To do this, simply go to the menu «Administration» > «Profiles», to select the profile you wish to modify, then in the
«Uninstallation» tab set the following options :

• No access: the plugin does not appear in the menu “Plugin”.

• Playback: only the use of previously created templates is possible

• Writing: Template creation is possible.

• Hardware replacement: standard hardware replacement is possible

18.4 Uninstall feature

This functionality of the plugin “Item Uninstallation” adds the possibility of modifying the value of certain fields and
of removing the inventory of a computer of the OCS base or the cleaning of the FusionInventory tables.

The uninstall templates can be accessed in the «Administration > Uninstall Hardware» menu.

You can create as many uninstall templates as you want. Each template can contain different features, and be visible in
the sub-entities or not.

Uninstall equipment is a transfer of the equipment to itself. During its transfer, a certain number of actions are perfor-
med, as specified in the definition of transfer.

• Name: the name of the uninstall template

• Sub-entities: indicates whether the template is visible in the creation entity and its sub-entities

• Model type: indicates which type of model should be used (either Uninstall or Replace)

• Comments: free fields to add details about the model
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• Transfer template to be used: Indicates the transfer template to be used when uninstalling the system.

• New hardware status: indicates which status the hardware should take once uninstalled

• New group: indicates the group to which the hardware can belong once uninstalled.

• Software History Deletion : Allows deletion of all lines in a computer’s history that are relevant to software
installations/uninstallations.

• REMOVE Name : removes the name of the hardware during uninstallation

• RAZ Contact : removes the contact reassembled by OCS during uninstallation

• Network reset: resets the «network» field of the equipment record to zero.

• RAZ OS: Removes OS information (OS, Version, Service Pack, Product Key, Product ID) when uninstalling.

• RAZ domain : removes the «domain» field from the hardware

• Remove IP & Gateway & Hacker & Subnet: removes network information (except for the MAC address, which
is hardware-related) during uninstallation

• Remove the machine from OCS : when uninstalling a computer in GLPI, remove from the OCS base the corres-
ponding machine

• Delete FusionInventory info: Delete all FusionInventory info for this material

18.5 Uninstall hardware

There are 2 possibilities to uninstall a hardware:

• from its file, in the tab «Uninstallation».

• from the massive modifications list

Since a template can be recursive (visible in the sub-entities), the list of templates displayed in the massive actions
indicates all the templates available in the current entity (either those defined in this entity, or in an entity above it and
visible in the sub-entities).
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18.5.1 Change of location on uninstallation

It is possible to change the location of the hardware once it has been uninstalled. This selection is made either :

• in the hardware file, once the uninstallation model has been chosen.

• from the user’s preferences for uninstallation by massive modification

It should be noted that a location is declared within an entity. It is therefore possible, depending on the current entity,
to define an uninstall location.

18.6 Replace feature

This feature of the “Item Uninstallation” plugin adds the possibility to replace one hardware by another.

18.6.1 Replacement Model Form

Replacement models are managed in the same way as uninstall models: They are accessible in the menu «Adminis-
tration > Uninstall hardware». Each model can contain different characteristics, and be visible in the sub-entities or
not.

In this form there are 4 tabs :

• Main: allows to display on the page only the main information of the template.

• Replacing data: displays the various actions to be performed when replacing one piece of equipment with another.

• All: displays all the tabs on the same page

Here is the description of the fields of the main tab :

Name: the name of the replacement model Sub-entities: indicates whether the template is visible in the creation entity
and its sub-entities Model type: indicates what type of model should be used (here we are talking about type - Re-
placement) Comments: free fields to add details about the model New hardware status: indicates which status the old
hardware should take once it has been replaced
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18.6.2 Replacing data tab

Here is the description of the fields of the actions tab.

General Information

• Copy name: allows you to define if you want to copy the name of the old hardware to the new one.

• Copy the serial number: Allows you to define if you wish to copy the serial number of the old equipment to the
new one.

• Copy the inventory number: allows you to define if you want to copy the inventory number of the old equipment
to the new one.

• Overwrite information (from the old material to the new one): this option allows you to choose the behavior to
adopt if one of the unique information (Reservation, Financial Information, Name, Serial, Otherserial, Entity. . . )
is present in the old material AND in the new material : Yes : by selecting YES, the information in the old
material will replace that in the new material. No: by selecting NO, the information of the new hardware will
NEVER be overwritten by the information of the old hardware.

Method of archiving old material

In this option, we define the behavior that the uninstall plugin must adopt with the old hardware :

• Purge + PDF / CSV : if you have the PDF plugin the old hardware will be purged from the GLPI database and its
information will be attached to the new hardware in a PDF document. If you do not have the PDF plugin, they
will be stored in CSV format.

• Deletion + Comments: the old hardware is put in the trash and a comment is added in each of the two hardware
(«This hardware has been replaced by. . . » and «This hardware has replaced the hardware. . . »).

Data location - Connection with other hardware

• Copy Documents: Allows you to attach documents from old equipment to new equipment.

• Copy Contracts: allows you to attach the contracts from the old equipment to the new equipment.

• Copy financial information: allows you to attach financial information from the old equipment to the new equip-
ment. Warning: if the «Overwrite information» option is activated, even if the new hardware has financial
information, it will be replaced by the old hardware.

• Copy Reservations: Allows you to attach the reservations made on the old equipment to the new equipment.
Attention: same remark as for the financial information.
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• Copy the user: allows you to pass on the user of the old equipment to the new one. Caution: same remark as for
the financial information.

• Copy group: Allows you to assign the group of the old equipment to the new equipment. Caution: same remark
as for the financial information.

• Copy the tickets: Allows you to attach the tickets of the old equipment to the new equipment.

• Copy network connections: Allows you to transfer the network connections from the old hardware to the new
hardware.

• Copy direct connections: Allows you to transfer the direct connections (Monitor, Printer, Device, Phone) from
the old hardware to the new hardware.

18.7 Replace hardware

As well as uninstalling equipment, there are two ways to replace equipment:

• from the card of this one, in the tab «Plugins -> Uninstallation»,

• from the massive modification list.

Since a replacement template can be recursive (visible in the sub-entities), the list of templates displayed in the massive
actions indicates all the templates available in the current entity (either those defined in this entity, or in an entity above
it and visible in the sub-entities).

Once you have selected the hardware to be replaced via the massive actions, or you use the «Uninstall» tab directly in
it :

• a summary of the selected template appears in order to show you the actions that will be performed by the plugin.

• the list of the selected hardware(s) appears and you can choose the replacement hardware in the same way as
when you choose a hardware in a Support Ticket.
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18.7.1 Change of location on replacement

It is possible to change the location of the equipment once it has been replaced. This selection is made either :

• in the equipment sheet, once the replacement model has been chosen,

• from the user’s preferences for massive modification replacement.

Note that a location is declared within an entity. It is therefore possible, depending on the current entity, to define a
replacement location.

18.8 FAQ

If you have any questions about using the plugin, please consult our FAQ

18.8. FAQ 139

https://faq.teclib.com/04_Plugins/Uninstall/
http://creativecommons.org/licenses/by-nc-nd/4.0/


GLPI plugins Documentation

140 Capítulo 18. Uninstall



CAPÍTULO 19

Painéis de visualização avançadas

19.1 Requisitos (localmente)

Versão do GLPI PHP mínimo Recomendado
10.0.x 8.1 8.2

Nota: A standard licence (or higher) is required. This plugin is also available from the Cloud.

19.2 Instalar o plugin

• Vá para o marketplace. Baixe e instale o plugin «Painéis de visualização avançados*».
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19.3 Configurar o plugin

Aviso: Este plugin requer um conhecimento mínimo de SQL para ser capaz de definir certos critérios para as
várias consultas que aparecerão nos painéis. Também é recomendado que você conheça a estrutura das tabelas
do GLPI.

19.3.1 Criar uma consulta SQL

O exemplo abaixo nos dá o número de ingressos na entidade raiz nos últimos 2 anos.

SELECT YEAR(t.date_creation) as 'Year', count(*) as 'Volume of tickets'
FROM glpi_tickets t
JOIN glpi_entities e on t.entities_id = e.id
WHERE e.completename LIKE "Root entity"

AND YEAR(t.date_creation) > YEAR(CURRENT_DATE()) - 5
GROUP BY YEAR(t.date_creation)
UNION
SELECT

CONCAT('Estimated total end ', YEAR(CURRENT_DATE())),
ROUND(

(
SELECT count(*)
FROM glpi_tickets t4
JOIN glpi_entities e4 on t4.entities_id = e4.id

WHERE e4.completename LIKE "Entité racine" (root entity)
AND YEAR(t4.date_creation) = YEAR(CURRENT_DATE()) - 1

) *
(

(
SELECT count(*)
FROM glpi_tickets t3
JOIN glpi_entities e3 on t3.entities_id = e3.id
WHERE e3.completename LIKE "Root entity"

AND YEAR(t3.date_creation) = YEAR(CURRENT_DATE())
)
/
(

SELECT count(*)
FROM glpi_tickets t2
JOIN glpi_entities e2 on t2.entities_id = e2.id
WHERE e2.completename LIKE "Root entity"

AND YEAR(t2.date_creation) = (YEAR(CURRENT_DATE()) - 1)
AND (

MONTH(t2.date_creation) < MONTH(CURRENT_DATE())
OR MONTH(t2.date_creation) = MONTH(CURRENT_DATE()) AND DAY(t2.

→˓date_creation) <= DAY(CURRENT_DATE())
)

)
)

(continues on next page)
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(continuação da página anterior)

)

19.3.2 Definindo parâmetros relacionados à consulta

• De ferramentas > SQL para painéis, clique em adicionar

• Nomeie sua consulta (aquela que será visível nos painéis) e identifique-a como ativa.

• Na guia Editor SQL, cole a consulta acima, tomando cuidado para alterar o nome da entidade, caso você tenha
alterado.

• Clique no ícone do disquete para salvar a consulta e depois no ícone de reprodução para executar a consulta.

Um inserir na parte inferior exibirá o resultado da consulta:

• Na guia configurar campos, defina o rótulo, o número e o rótulo principal (opcional, este é o nome que sua
tabela terá). No nosso caso, o rótulo será «ano», o número será «número de ingressos» e o rótulo principal será
«número de ingressos por ano»

• Selecione o tipo de gráfico (isso é apenas a título informativo, para que você possa visualizar sua tabela; você
será solicitado a selecionar o tipo de gráfico que deseja que apareça no bloco mais tarde),

• Você pode limitar a quantidade de dados a serem mostrados.

• Então clique em Salvar campos e visualizar.
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19.3.3 Configuração de painel de visualização

• Do Assistência > Painel de controle, selecione o painel de controle que irá receber o novo bloco

• Clique no ícone de edição

• Adicione um novo bloco com ícone de adição

• Selecione a consulta que você acabou de criar

• Escolha uma cor para o seu bloco

• Você será então solicitado a selecionar o tipo de gráfico.

• Alguns painéis podem solicitar que você use cores e exiba valores e rótulos.

• Seu título está pronto agora.

19.4 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 20

Anonymize

20.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available from the Cloud.

20.2 Install the plugin

• Go to the marketplace. Download and install the “Anonymize” plugin.
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20.3 Choice of profile

Anonymisation works by profile. There are 4 profiles already created. When you select a profile, a certain amount of
data is already set. They can, of course, be modified.

• Go to Administration > Anonymization profile and select the profile best suited to your needs:

The 4 profiles you will find are :

• Email

• Entity

• Computer

• User profile

20.4 Anonymisable data per profile (predefined)

Each profile has an element assigned to it. You will need to define the value of each attribute that it will be able to
anonymise (or not)
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20.4.1 Email

• users_id

• is_default

• email

20.4.2 Entity

• name

• entities_id

• comment

• level

• sons_cache

• ancestors_cache

• address

• postcode

• town

• state

• country

• website

• phonenumber

• fax

• email

• admin_email

• admin_email_name

• from_email

• from_email_name

• noreply_email

• noreply_email_name

• replyto_email

• replyto_email_name

• notification_subject_tag

• ldap_dn

• tag

• authldaps_id

• mail_domain

• entity_ldapfilter
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• mailing_signature

• cartridges_alert_repeat

• consumables_alert_repeat

• use_licenses_alert

• send_licenses_alert_before_delay

• use_certificates_alert

• send_certificates_alert_before_delay

• certificates_alert_repeat_interval

• use_contracts_alert

• send_contracts_alert_before_delay

• use_infocoms_alert

• send_infocoms_alert_before_delay

• use_reservations_alert

• use_domains_alert

• send_domains_alert_close_expiries_delay

• send_domains_alert_expired_delay

• autoclose_delay

• autopurge_delay

• notclosed_delay

• calendars_strategy

• calendars_id

• auto_assign_mode

• tickettype

• max_closedate

• inquest_config

• inquest_rate

• inquest_delay

• inquest_URL

• autofill_warranty_date

• autofill_use_date

• autofill_buy_date

• autofill_delivery_date

• autofill_order_date

• tickettemplates_strategy

• tickettemplates_id

• changetemplates_strategy
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• changetemplates_id

• problemtemplates_strategy

• problemtemplates_id

• entities_strategy_software

• entities_id_software

• default_contract_alert

• default_infocom_alert

• default_cartridges_alarm_threshold

• default_consumables_alarm_threshold

• delay_send_emails

• is_notif_enable_default

• inquest_duration

• date_mod

• date_creation

• autofill_decommission_date

• suppliers_as_private

• anonymize_support_agents

• display_users_initials

• contracts_strategy_default

• contracts_id_default

• enable_custom_css

• custom_css_code

• latitude

• longitude

• altitude

• transfers_strategy

• transfers_id

• agent_base_url

20.4.3 Computer

• entities_id

• name

• serial

• otherserial

• contact

• contact_num
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• users_id_tech

• groups_id_tech

• comment

• date_mod

• autoupdatesystems_id

• locations_id

• networks_id

• computermodels_id

• computertypes_id

• template_name

• manufacturers_id

• users_id

• groups_id

• states_id

• ticket_tco

• uuid

• date_creation

• last_inventory_update

• last_boot

20.4.4 User

• name

• password

• password_last_update

• phone

• phone2

• mobile

• realname

• firstname

• locations_id

• language

• use_mode

• is_active

• comment

• auths_id

• authtype
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• last_login

• date_mod

• date_sync

• profiles_id

• entities_id

• usertitles_id

• usercategories_id

• password_forget_token

• password_forget_token_date

• user_dn

• personal_token

• personal_token_date

• api_token

• api_token_date

• cookie_token

• cookie_token_date

• isd_ldap

• picture

• begin_date

• end_date

• page_layout

• fold_menu

• fold_search

• savedsearches_pinned

• timeline_order

• itil_layout

• richtext_layout

• date_creation

• groups_id

• users_id_supervisor

• timezone

• default_central_tab

• nickname

• timeline_action_btn_layout

• timeline_date_format

• use_flat_dropdowntree_on_search_result
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20.5 Application strategy

Several strategies are available for each element field (e.g.Last name, First name, Serial number, Location, Status, etc.):

• Keep the value

• Delete the value

• Replace with a fixed value

• Replace with a standard random value

• Replace with a realistic random value

20.6 History

Each profile allows you to choose the treatment to be applied to the history of items:

• Do nothing

• Clean up values

• Clean up recent values and delete the rest

• Delete

20.7 Global search

You can ask GLPI to anoymise an attribute in the whole database and not only in the type of element you are in. The
option attributes to search and replace in others objects is at the very bottom of your profile.

Nota: You cannot change any values other than those linked to the type of element you are in. For example, you will
be able to modify all email addresses in the database via the Email profile, but you will not be able to modify all user
phone number via this profile.

20.8 Applying the profile

Once you have completed your profile, you need to apply it. It can be applied using 2 methods:

• Massive action via the web interface (cloud and on-premise)

• In CLI (only on-premise)
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20.8.1 Mass action (Cloud and on-premise)

In our example, we will be anonymising user data.

• Go to Administration > Users. Select the user(s) you wish to anonymise.

• Click on Actions then anonymise selected items.

Nota: «To be adapted If your profile concerns entities, go to Administration > Entities and repeat the operation for
the entities concerned. Do the same for computers, email, etc.

20.8.2 Via CLI (on-premise only)

• Go to your GLPI folder (/var/www/glpi or other depending on your configuration):

• Run all default profiles on all objects:

$ php bin/console glpi:plugin:anonymize --all

• Run profile X on all objects / on one object:

$ php bin/console glpi:plugin:anonymize --profile=X
$ php bin/console glpi:plugin:anonymize --profile=X --item-id=X

• Run default profile type X on all objects / on one object :

$ php bin/console glpi:plugin:anonymize --itemtype=X
$ php bin/console glpi:plugin:anonymize --itemtype=X --item-id=X

20.9 Creating a profile

You can create a profile to anonymise other data than that mentioned above.

• Go to Administration > Anonymisation profile

• Click on Add

• Name your profile

• Choose from the list of Element types (agent, domain, etc.)

• Select the treatment of the History

• Set the parameters for each field

• Click on Add

Nota: Remember to refer to the profile application section to apply your changes.
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20.10 Other anonymisable data (profile creation)

20.10.1 Agents

• deviceid

• entities_id

• name

• agenttypes_id

• last_contact

• version

• locked

• itemtype

• items_id

• useragent

• tag

• port

• threads_networkdiscovery

• threads_networkinventory

• timeout_networkdiscovery

• timeout_networkinventory

• remote_addr

• use_module_wake_on_lan

• use_module_computer_inventory

• use_module_esx_remote_inventory

• use_module_remote_inventory

• use_module_network_inventory

• use_module_network_discovery

• use_module_package_deployment

• use_module_collect_data

20.10.2 Appliances

• entities_id

• Garder

• name

• appliancetypes_id

• comment

• locations_id
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• manufacturers_id

• applianceenvironments_id

• users_id

• users_id_tech

• groups_id

• groups_id_tech

• date_mod

• date_creation

• states_id

• externalidentifier

• serial

• otherserial

• is_helpdesk_visible

• pictures

• contact

• contact_num

20.10.3 Budgets

• name

• entities_id

• comment

• begin_date

• end_date

• value

• template_name

• date_mod

• date_creation

• locations_id

• budgettypes_id
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20.10.4 Cables

• name

• entities_id

• itemtype_endpoint_a

• itemtype_endpoint_b

• items_id_endpoint_a

• items_id_endpoint_b

• socketmodels_id_endpoint_a

• socketmodels_id_endpoint_b

• sockets_id_endpoint_a

• sockets_id_endpoint_b

• cablestrands_id

• color

• otherserial

• states_id

• users_id_tech

• cabletypes_id

• comment

• date_mod

• date_creation

20.10.5 Changes

• name

• entities_id

• status

• content

• date_mod

• date

• solvedate

• closedate

• time_to_resolve

• users_id_recipient

• users_id_lastupdater

• urgency

• impact
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• priority

• itilcategories_id

• impactcontent

• controlistcontent

• rolloutplancontent

• backoutplancontent

• checklistcontent

• global_validation

• validation_percent

• actiontime

• begin_waiting_date

• waiting_duration

• close_delay_stat

• solve_delay_stat

• date_creation

• locations_id

20.10.6 Certificates

• name

• serial

• otherserial

• entities_id

• comment

• template_name

• certificatetypes_id

• dns_name

• dns_suffix

• users_id_tech

• groups_id_tech

• locations_id

• manufacturers_id

• contact

• contact_num

• users_id

• groups_id

• is_autosign
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• date_expiration

• states_id

• command

• certificate_request

• certificate_item

• date_creation

• date_mod

20.10.7 Clusters

• entities_id

• name

• uuid

• version

• users_id_tech

• groups_id_tech

• states_id

• comment

• clustertypes_id

• autoupdatesystems_id

• date_mod

• date_creation

20.10.8 Contacts

• name

• firstname

• phone

• phone2

• mobile

• fax

• email

• contacttypes_id

• comment

• usertitles_id

• address

• postcode

• town
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• state

• country

• date_mod

• date_creation

• pictures

20.10.9 Databases

• entities_id

• name

• size

• databaseinstances_id

• is_onbackup

• is_active

• date_creation

• date_mod

• date_update

• date_lastbackup

20.10.10 Datacenters

• name

• entities_id

• locations_id

• date_mod

• date_creation

• pictures

20.10.11 Server rooms

• name

• entities_id

• locations_id

• vis_cols

• vis_rows

• blueprint

• datacenters_id

• date_mod
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• date_creation

20.10.12 Documents

• name

• filename

• filepath

• documentcategories_id

• mime

• date_mod

• comment

• link

• users_id

• tickets_id

• sha1sum

• is_blacklisted

• tag

• date_creation

20.10.13 Domains

• name

• entities_id

• domaintypes_id

• date_expiration

• date_domaincreation

• users_id_tech

• groups_id_tech

• comment

• template_name

• is_active

• date_mod

• date_creation
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20.10.14 Enclosures

• name

• entities_id

• locations_id

• serial

• otherserial

• enclosuremodels_id

• users_id_tech

• groups_id_tech

• template_name

• orientation

• power_supplies

• states_id

• comment

• manufacturers_id

• date_mod

• date_creation

20.10.15 Groups

• entities_id

• name

• comment

• ldap_field

• ldap_value

• ldap_group_dn

• date_mod

• groups_id

• level

• ancestors_cache

• sons_cache

• is_requester

• is_watcher

• is_assign

• is_task

• is_notify
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• is_itemgroup

• is_usergroup

• is_manager

• date_creation

20.10.16 Knowledge base

• name

• answer

• is_faq

• users_id

• view

• date_creation

• date_mod

• begin_date

• end_date

20.10.17 ITIL Categories

• entities_id

• itilcategories_id

• name

• comment

• level

• knowbaseitemcategories_id

• users_id

• groups_id

• code

• ancestors_cache

• sons_cache

• is_helpdeskvisible

• tickettemplates_id_incident

• tickettemplates_id_demand

• changetemplates_id

• problemtemplates_id

• is_incident

• is_request

• is_problem

166 Capítulo 20. Anonymize



GLPI plugins Documentation

• is_change

• date_mod

• date_creation

20.10.18 Followups

• itemtype

• items_id

• date

• users_id

• users_id_editor

• content

• is_private

• requesttypes_id

• date_mod

• date_creation

• timeline_position

• sourceitems_id

• sourceof_items_id

20.10.19 Followups templates

• date_creation

• date_mod

• entities_id

• name

• content

• requesttypes_id

• is_private

• comment

20.10.20 Solutions

• itemtype

• Keep

• items_id

• solutiontypes_id

• solutiontype_name
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• content

• date_creation

• date_mod

• date_approval

• users_id

• user_name

• users_id_editor

• users_id_approval

• user_name_approval

• status

• itilfollowups_id

20.10.21 Lines

• name

• entities_id

• caller_num

• caller_name

• users_id

• groups_id

• lineoperators_id

• locations_id

• states_id

• linetypes_id

• date_creation

• date_mod

• comment

20.10.22 Locations

• entities_id

• name

• locations_id

• comment

• level

• ancestors_cache

• sons_cache

• address
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• postcode

• town

• state

• country

• building

• room

• latitude

• longitude

• altitude

• date_mod

• date_creation

20.10.23 Monitors

• entities_id

• name

• date_mod

• contact

• contact_num

• users_id_tech

• groups_id_tech

• comment

• serial

• otherserial

• size

• have_micro

• have_speaker

• have_subd

• have_bnc

• have_dvi

• have_pivot

• have_hdmi

• have_displayport

• locations_id

• monitortypes_id

• monitormodels_id

• manufacturers_id
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• is_global

• template_name

• users_id

• groups_id

• states_id

• ticket_tco

• autoupdatesystems_id

• uuid

• date_creation

20.10.24 Network devices

• entities_id

• name

• ram

• serial

• otherserial

• contact

• contact_num

• users_id_tech

• groups_id_tech

• date_mod

• comment

• locations_id

• networks_id

• networkequipmenttypes_id

• networkequipmentmodels_id

• manufacturers_id

• template_name

• users_id

• groups_id

• states_id

• ticket_tco

• uuid

• date_creation

• autoupdatesystems_id

• sysdescr
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• cpu

• uptime

• last_inventory_update

• snmpcredentials_id

20.10.25 PDUs

• name

• entities_id

• locations_id

• serial

• otherserial

• pdumodels_id

• users_id_tech

• groups_id_tech

• template_name

• states_id

• comment

• manufacturers_id

• pdutypes_id

• date_mod

• date_creation

20.10.26 Projects

• name

• code

• priority

• entities_id

• projects_id

• projectstates_id

• projecttypes_id

• date

• date_mod

• users_id

• groups_id

• plan_start_date

• plan_end_date
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• real_start_date

• real_end_date

• percent_done

• auto_percent_done

• show_on_global_gantt

• content

• comment

• date_creation

• projecttemplates_id

• template_name

20.10.27 Projects tasks

• uuid

• name

• content

• comment

• entities_id

• projects_id

• projecttasks_id

• date_creation

• date_mod

• plan_start_date

• plan_end_date

• real_start_date

• real_end_date

• planned_duration

• effective_duration

• projectstates_id

• projecttasktypes_id

• users_id

• percent_done

• auto_percent_done

• is_milestone

• projecttasktemplates_id

• template_name
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20.10.28 Devices

• entities_id

• name

• date_mod

• contact

• contact_num

• users_id_tech

• groups_id_tech

• comment

• serial

• otherserial

• locations_id

• peripheraltypes_id

• peripheralmodels_id

• brand

• manufacturers_id

• is_global

• template_name

• users_id

• groups_id

• states_id

• ticket_tco

• autoupdatesystems_id

• uuid

• date_creation

20.10.29 Phones

• entities_id

• name

• date_mod

• contact

• contact_num

• users_id_tech

• groups_id_tech

• comment
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• serial

• otherserial

• locations_id

• phonetypes_id

• phonemodels_id

• brand

• phonepowersupplies_id

• number_line

• have_headset

• have_hp

• manufacturers_id

• is_global

• template_name

• users_id

• groups_id

• states_id

• ticket_tco

• autoupdatesystems_id

• uuid

• date_creation

• last_inventory_update

20.10.30 Printers

• entities_id

• name

• date_mod

• contact

• contact_num

• users_id_tech

• groups_id_tech

• serial

• otherserial

• have_serial

• have_parallel

• have_usb

• have_wifi
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• have_ethernet

• comment

• memory_size

• locations_id

• networks_id

• printertypes_id

• printermodels_id

• manufacturers_id

• is_global

• template_name

• init_pages_counter

• last_pages_counter

• users_id

• groups_id

• states_id

• ticket_tco

• uuid

• date_creation

• sysdescr

• last_inventory_update

• snmpcredentials_id

• autoupdatesystems_id

20.10.31 Problems

• name

• entities_id

• status

• content

• date_mod

• date

• solvedate

• closedate

• time_to_resolve

• users_id_recipient

• users_id_lastupdater

• urgency
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• impact

• priority

• itilcategories_id

• impactcontent

• causecontent

• symptomcontent

• actiontime

• begin_waiting_date

• waiting_duration

• close_delay_stat

• solve_delay_stat

• date_creation

• locations_id

20.10.32 Racks

• name

• comment

• entities_id

• locations_id

• serial

• otherserial

• rackmodels_id

• manufacturers_id

• racktypes_id

• states_id

• users_id_tech

• groups_id_tech

• width

• height

• depth

• number_units

• template_name

• dcrooms_id

• room_orientation

• position

• bgcolor
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• max_power

• mesured_power

• max_weight

• date_mod

• date_creation

20.10.33 Rules

• entities_id

• sub_type

• ranking

• name

• description

• match

• is_active

• comment

• date_mod

• uuid

• condition

• date_creation

20.10.34 Saved searches

• name

• type

• itemtype

• users_id

• is_private

• entities_id

• query

• last_execution_time

• do_count

• last_execution_date

• counter
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20.10.35 Software

• entities_id

• name

• comment

• locations_id

• users_id_tech

• groups_id_tech

• is_update

• softwares_id

• manufacturers_id

• template_name

• date_mod

• users_id

• groups_id

• ticket_tco

• is_helpdesk_visible

• softwarecategories_id

• is_valid

• date_creation

• pictures

20.10.36 Licenses

• softwares_id

• softwarelicenses_id

• level

• entities_id

• number

• softwarelicensetypes_id

• name

• serial

• otherserial

• softwareversions_id_buy

• softwareversions_id_use

• expire

• comment
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• date_mod

• is_valid

• date_creation

• locations_id

• users_id_tech

• users_id

• groups_id_tech

• groups_id

• is_helpdesk_visible

• template_name

• states_id

• manufacturers_id

• contact

• contact_num

• allow_overquota

• pictures

• ancestors_cache

• sons_cache

20.10.37 Solutions templates

• entities_id

• name

• content

• solutiontypes_id

• comment

• date_mod

• date_creation

20.10.38 Solutions types

• name

• comment

• entities_id

• date_mod

• date_creation
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20.10.39 Suppliers

• entities_id

• name

• suppliertypes_id

• address

• postcode

• town

• state

• country

• website

• phonenumber

• comment

• fax

• email

• date_mod

• date_creation

• is_active

• pictures

20.10.40 Task categories

• entities_id

• taskcategories_id

• name

• comment

• level

• ancestors_cache

• sons_cache

• is_active

• is_helpdeskvisible

• date_mod

• date_creation

• knowbaseitemcategories_id
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20.10.41 Task templates

• entities_id

• name

• content

• taskcategories_id

• actiontime

• comment

• date_mod

• date_creation

• state

• is_private

• users_id_tech

• groups_id_tech

20.10.42 Tickets

• entities_id

• name

• date

• closedate

• solvedate

• takeintoaccountdate

• date_mod

• users_id_lastupdater

• status

• users_id_recipient

• requesttypes_id

• content

• urgency

• impact

• priority

• itilcategories_id

• type

• global_validation

• slas_id_ttr

• slas_id_tto
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• slalevels_id_ttr

• time_to_resolve

• time_to_own

• begin_waiting_date

• sla_waiting_duration

• ola_waiting_duration

• olas_id_tto

• olas_id_ttr

• olalevels_id_ttr

• ola_ttr_begin_date

• internal_time_to_resolve

• internal_time_to_own

• waiting_duration

• close_delay_stat

• solve_delay_stat

• takeintoaccount_delay_stat

• actiontime

• locations_id

• validation_percent

• date_creation

• ola_tto_begin_date

20.10.43 Ticket tasks

• uuid

• tickets_id

• taskcategories_id

• date

• users_id

• users_id_editor

• content

• is_private

• actiontime

• begin

• end

• state

• users_id_tech
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• groups_id_tech

• date_mod

• date_creation

• tasktemplates_id

• timeline_position

• sourceitems_id

• sourceof_items_id

20.10.44 Ticket templates

• name

• entities_id

• comment

20.11 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 21

Approval by mail

21.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: standard license (or higher) is required. This plugin is also available from the Cloud.

21.2 Install the plugin

• Go to the marketplace. Download and install the plugin ApprovalByMail.
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21.3 Using the plugin

Once activated, there are no specific settings to be made (apart from the notification layout, if you wish, via Setup >
Notifications > Notification templates. The template is Tickets validation)

• In a new ticket, enter the name of the person or group receiving the approval request.

An email will be received with the option of Validating or Refusing the request. This contains 3 links (if no changes
have been made to the model).

• The ticket reminder

• The acceptance link

• The refusal link

• When the form is validated, you are redirected to GLPI with a notification of acceptance:

• If the form is refused, a comment will be requested to validate the refusal:

• It is not possible to reply 2 times to the validation, an error message will be displayed:
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21.4 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 22

Branding

22.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available from the Cloud.

22.2 Install the plugin

• Go to the marketplace. Download and install the Branding plugin.
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22.3 Customize your instance

• Go to administration > entities > branding tab

Here you can replace :

• the logo at top left (including folded bar)

• the logo on the login page,

• the background of the login page,

• the icon in the browser bar

22.4 Custom by entity

You can modify certain elements by entity:

• the logo at top left (including folded bar)

• the icon in the browser bar

Other customisations are common to all entities
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22.5 Recommendations

• Top Left corner logo - This can be changed according to the desired entity It is the logo you see when your
GLPI page is opened and the left sidebar is expanded

Default recommended size: 100x55 pixels

• Lop Left corner logo (collapsed sidebar) - This can be changed according to the desired entity It is the logo you
see when your GLPI page is opened and the left sidebar is collapsed.

Default recommended size 40x40 pixels

• Favicon It is the logo you see next to the page title at the beginning of your browser’s the tab.

Default recommended size: 16x16 or 32x32 pixels

• Login page logo It is the logo you see before you login. It appears with the fields to fill with your username and
password

Default recommended size: 220x130 pixels

• Login page background It is the image you can add as a background at the login page.

Default recommended size: It depends on the usual size of your screens. The bigger, the better. (Make sure not to
surpass the maximum upload limit for files)

22.6 FAQ

If you have any questions about using the plugin, please consult our FAQ
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Collaborative tools

23.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available on Cloud.

23.1.1 Install the plugin

• Go to the marketplace. Download and install the plugin Collaborative tools.
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23.1.2 Activate webhooks

• In the tab Setup > Notifications activate Webhooks notifications

23.1.3 Mattermost

• From a Mattermost administrator account, go to the menu at the top left,

• Then Integrations

• Select Incoming Webhooks

• Then Add a new incoming webhook.

• Fill in the necessary fields and select the channel that will receive the notifications

• Then click on Save.

• You will then be sent the link to your Webhook:
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23.1.4 Telegram

• From Telegram, start a new chat with the bot @BotFather and run the following command /newbot

• Answer the few questions you will be asked to set up your bot

• Once finished, a token will be sent to you:

• If you have already created a dedicated channel to receive GLPI notifications, add your bot to it.

• Otherwise, create your own channel

• add the newly created bot

• Send a message in the channel created to initiate a conversation and generate the various IDs we will need.
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• From your browser, enter the following URL:

https://api.telegram.org/botmytoken/getupdates

Replace mytoken with the value of the token generated above

Nota: Telegram bot URLs take the form https://api.telegram.org/bot{mytoken}

• You should see a similar result:

"ok": true,
"result": [

{
"update_id": 816584684,
"my_chat_member": {

"chat": {
"id": -541684658463,
"title": "GLPI Ticket",
"type": "channel"

},
"from": {

"id": 1546610935,
"is_bot": false,
"first_name": "xxxxxxx",
"last_name": "xxxxxxx"

},
"new_chat_member": {

"user": {
"id": 7468746847,
"is_bot": true,
"first_name": "glpi",
"username": "xxxxxx_bot"

• In the my_chat_member copy the ID value of the chat.

Aviso: The negative sign - must also be copied

23.1.5 Teams

• From a Teams administrator account, go to the channel that will receive GLPI notifications

• Click on the channel menu

• Then Manage channel

• In the Connectors section,

• click on Modify

• From the incoming Webhook connector
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• click on Configure

• Enter a name for your webhook and an image (optional)

• Click on Create

• You will then be sent the URL of your webhook

23.1.6 Rocket

• You need to add an application to your team (the link is present in the bottom of the left sidebar) and select
incoming-webhook

• Add a new configuration, select the channel where you want notifications and you will get the webhook url.

• You can optionally setup a name and a logo for your hook.

23.1.7 Slack

• As a logged team administrator, go to the administration menu

• click on Integrations menu item

• Click on the New integration button

• Select incoming webhooks, and define webhook parameters

• After save, you will get the url of the webhook.
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23.1.8 Set up the webhook in GLPI

• Fill in the requested information and select the channel on which you want the notifications to be sent.

• Once registered, a link will be sent to you. Copy this link and transfer it to Setup > Notifications > Configuration
of notifications by webhooks

• Click on + and enter :

– Webhook name,

– the type,

– the URL.

• Click on Add

Aviso: For Telegram, you will need to re-enter the webhook and add the chat_id you selected earlier

• You can test how it works by selecting your webhook and clicking on Send notification
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23.1.9 Recipients

• You now need to determine which notifications will be affected by the sending of a Webhook and assign them a
template.

• Go to Setup > Notifications > Notifications

• Select the 1st notification concerned by Webhooks (here New ticket)

• In the Recipients tab, add your Webhook then Update.

23.1.10 Templates

• In the tab Templates click Add a template

• Choose Webook in the Notification method and New in the Notification template

Your Webhook is ready to use. You can customise the template by clicking on New so that it matches your
requirements.
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23.1.11 FAQ

If you have any questions about using the plugin, please consult our FAQ
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GDPR Tools

24.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic license (or higher) is required. This plugin is also available from the Cloud.

24.2 Install the plugin

• Go to the marketplace. Download and install the GDPR Tools plugin.
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24.3 Configure the plugin

• From Setup > General > GDPR tools

24.3.1 Cleaning up inactive users

There are two possible ways of managing inactive users:

• Clearing the user’s data

• Deleting the user

24.3.2 Cleaning up user data

When the plugin is configured in Clean mode, the following actions will be performed:

• Delete all references to the user from the GLPI history

• Delete all associated emails

• Reset all user fields and profiles

• Move the user to the recycle bin

24.3.3 Delete the user

When the plugin is configured in “Delete” mode, the following actions will be performed:

• Delete all references to the user from the GLPI history

• Delete all associated emails

• Delete the user

Aviso: Deletion is permanent, the user cannot be recovered

24.3.4 Scope restriction

The automated deletion process can be restricted to the following scopes:

• All inactive users

• Inactive users with no current tickets

• Inactive users without tickets
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24.3.5 Automated action

Deletion will take place via a standard GLPI automatic action that can be configured to run as often as you like.

• Go to Setup > Automatic actions, and select the cleaninactiveuser action then configure it according to your
needs.

24.4 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 25

GLPI AI

25.1 Requirements

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

• Open AI API key (free or paid plan) (https://platform.openai.com/api-keys)

• Open AI organization ID (https://platform.openai.com/account/organization)

Nota: A basic license (or higher) is required. This plugin is not available from the Cloud.

25.2 Install the plugin

• Go to the marketplace. Download and install the GLPI AI plugin.
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25.3 Create an organization

After creating an OpenAI account, your can create an organization from your account settings under the Organization
tab or by accessing the page directly at https://platform.openai.com/account/organization.

Keep the Organization ID value, as you will need to insert it in the GLPI AI plugin configuration.
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25.4 Create a secret

• From this URL https://platform.openai.com/api-keys

• Click on Create a new secret

• Give a name to your secret

• Click on Create secret key

Copy the secret value that is generated as you will need it later to configure the plugin.
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25.5 Set up GLPI

• In GLPI, go to Setup > General > GLPI AI

• Fill in the fields with the values copied previously

• If your configuration is correct, you will be able to see your account entries, your consumption and your prefe-
rences.

25.6 Consumption

It is possible to limit the use of the API by specifying a limit that must not be exceeded. This plugin tracks usage based
on each response from OpenAI. Therefore, you may need to utilize the «Custom usage» field in the configuration to
account for usage outside of the plugin if you want the plugin to account for that in its usage limitation.

1. To limit usage and avoid overruns, specify a value that must not be exceeded. If this limit is exceeded, the plugin
will no longer function until this value is increased.

2. Enter the custom usage if you want to account for previous usage outside of the plugin.
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25.7 Preferences

In preferences, you can set up the response model. In Free mode, you can use the GPT-3.5 Turbo 16K model.

You can find information regarding the other plans and plan limits here

By clicking on Configure preferences, you can setup a context and a role.

• The Context can be a description of your company, your mission, your job in the company. AI needs to un-
derstand your context if it is to respond as pertinently as possible (there is a context by default that you can
change).

• The Role is how the AI should respond. Does it have a teaching, advisory or expert role? The role can influence
the tone and level of detail of the response (there is a role by default that you can change).

25.7. Preferences 217

https://platform.openai.com/account/limits
http://creativecommons.org/licenses/by-nc-nd/4.0/


GLPI plugins Documentation

25.8 Example

You can see an example of what can be achieved with an exchange that includes a lot of followups. The GLPI AI plugin
summarizes all of the followups to highlight the main information.

If you want another result, you can click on Refresh.
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CAPÍTULO 26

Holidays

26.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic license (or higher) is required. This plugin is also available from the Cloud.

26.2 Install the plugin

• Go to the marketplace. Download and install the Holiday plugin.
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26.3 Set up the plugin

• From Setup > General, in the Holiday tab, enter :

– The Country concerned

– The Number of years to insert

– Clean all previous holidays or not

– Then click on Insert holiday dates
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26.4 Delete a holiday date/period

The list of holiday days can be viewed and modified

• From Setup > Dropdowns,

• enter Closing and click on Closing times

The list of days appears. Let’s assume that the company considers that Easter Monday is not a day off.

• In the search box, enter Easter then Search

• Select all the entries

• Click on Actions

• Delete permanently

26.5 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 27

LDAP Tools

27.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available from the Cloud.

27.2 Install the plugin

• Go to the marketplace. Download and install the plugin LDAP Tools.
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27.3 Using the plugin

From tools > LDAP Tools, if you have synchronised LDAP directories, they will appear directly.

Each directory has a number of tests which may or may not be validated depending on your configuration:

• Flux TCP

• BaseDN

• LDAP URI

• Bind Auth

• Generic search

• Filtered search

• Attributes

As soon as one of the tests fails, the following tests will not be performed. You must start by correcting the 1st anomaly
before the other tests are run.
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Mais satisfação

28.1 Requisitos (localmente)

Versão do GLPI PHP mínimo Recomendado
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available on Cloud.

28.2 Instalar o plugin

• Vá para o marketplace. Baixe e instale o plugin Mais satisfação
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28.3 Criar uma pesquisa

• Uma vez instalado, vá para Administração > Pesquisa de satisfação

• Clique em Adicionar

• Nomeie sua pesquisa e defina-a como ativa

• Também lembre-se de marcar a caixa de subentidade se você deseja que ela esteja disponível para todas as
entidades filhas.

• Então clique em Adicionar

Aviso: É possível criar apenas uma pesquisa por entidade. Se você deseja criar várias pesquisas para entidades
diferentes, lembre-se de posicionar-se na entidade apropriada e não marque a caixa de sub-entidade.

28.4 Criar uma pergunta

• Digite sua pesquisa e vá para a guia Pergunta

• Clique em Adicionar uma pergunta

• Selecione o tipo de pergunta Sim/Não e digite o texto que lhe convém.

• Então clique em Adicionar
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28.5 Adicionar um campo de texto

• Na guia de perguntas, clique em Adicionar uma pergunta.

• Selecione o tipo de Texto

• Digite o texto a ser exibido e clique em Adicionar

28.6 Criar uma nota

• Na guia de perguntas, clique em Adicionar uma pergunta.

• Selecione o tipo de Nota

• Você pode selecionar uma pontuação até 10 e definir um valor padrão.

• Clique em «Adicionar» quando estiver satisfeito com suas configurações.

28.7 Pré-visualização

A guia de pré-visualização permite que você veja o que os usuários receberão assim que o ticket deles for fechado.
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28.8 Tradução

Você pode traduzir cada uma das perguntas feitas no questionário para o idioma de sua escolha.

• Vá para a guia Traduções

• Escolha o idioma que você deseja e, em seguida, pergunta por pergunta, escreva a tradução.

28.9 Agendar lembretes

No caso de não haver resposta à pesquisa, você pode enviar lembretes para fazer um acompanhamento com o usuário.
Você pode criar seu próprio lembrete ou selecionar um pré-definido.

28.9.1 Lembrete personalizado

• Ir para a guia Lembretes

• Clique em Adicionar um lembrete.

• Digite um:

– Nome

– Tipo de duração (dia ou mês)

– A duração do lembrete

– Ative seu lembrete
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28.9.2 Lembrete pré-definido

• Ir para a guia Lembretes

• Clique em Adicionar um lembrete predefinido

• Você terá 3 opções para escolher:

• 1 semana: lembrete a cada 7 dias,

• 2 semanas: lembrete a cada 14 dias.

• 1 mês: lembrete mensal.

• Selecione a opção que mais lhe convém e clique em Adicionar

28.9.3 Limite o número de lembretes

• Na seção Configurar o número máximo de dias para enviar lembrete, insira um limite para o Número má-
ximo de dias para enviar um lembrete.

Exemplo: Se uma pessoa não responder após 3 lembretes, o GLPI não enviará mais lembretes e a pesquisa de satisfação
ficará sem resposta.

28.10 Configurar a ação automática

Lembretes de pesquisa são enviados por meio de uma ação automática já criada pelo plugin. Certifique-se de que isso
esteja ativado e configurado corretamente.

• Ir para Configuração > Ações automáticas

• Selecione a ação LembretedeSatisfação.

28.10. Configurar a ação automática 229



GLPI plugins Documentation

28.11 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 29

OAuth SSO

29.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available from the Cloud.

29.2 External Authentication

The plugin uses GLPI’s External Authentication functionality and to be functional, it needs some initial Setup.

• Go to Setup > Authentication > Other authentication methods

• In the Other authentication transmitted in the HTTP request section

• The Storage fields for the identifier in the HTTP request field must be defined, usually HTTP_AUTH_USER.

• The Delete the domain from identifiers of the form identifier@domain field can be set to Yes or No.

Nota: In the case of authentication via SSO, the option Delete the domain of identifiers in the form identi-
fier@domain can be set to Yes, which will allow 2 user records to be merged if they are already present in the database
(internal or LDAP(S)).

Aviso: Be careful because this option is subject to identity theft. If your application is open to users other than
your own, it is possible that one user could be merged with another. For example, john.doe@mondomaine.fr has
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a namesake but a different email address john.doe@unautredomaine.fr. By deleting the domain, the 2 records
will be merged and the John Does will have the same account.

The users who are going to authenticate themselves will not be known to GLPI, so it is necessary to populate certain
fields to create their record in GLPI with a minimum of information.

The fields that can be retrieved by SSO are as follows:

• Last name : givenName

• First name: familyName

• Email: email

• Email2: email2

• Telephone number: phone

• Mobile: mobile

• Title: title

• Language: language

• Save your Setup

You must also activate the automatic addition of users in GLPI to create them in GLPI at the time of authentication

• In the Setup > Authentication > Setup menu

• The Automatically add users from external authentication sources field must be changed to Yes
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29.3 Fetch information from user profile option

You can choose if you want to retrieve informations from the user profile. In setup > Oauth SSO applications select
yes or no as required.

Importante: If OAuth SSO is your only source of authentication AND provisioning, we recommend that you set
the Fetch information from user profile option to Yes so that user information can be fetched. Please note that claims
must also be set correctly on the provider side.

If you are using an external provisioning source such as SCIM, we recommend that you set the Fetch information
from user profile option to No so that user information is not overwritten and replaced by that of the OAuth SSO
plugin.

29.4 Entra

29.4.1 Register your application in Entra

First, register your application with your Entra Active Directory (Entra AD) client. This will provide you with an
application ID for your application and allow it to receive tokens.

• Connect to the Entra portal

• Choose your Entra AD tenant by selecting your account in the top right corner of the page. Then select the
Change directory navigation bar, then the desired tenant

• Skip this step if you only have one Entra AD tenant under your account or if you have already selected one

• In the Entra Portal, search for and select Entra Active Directory

• From the left-hand Active Directory menu

• select Application Registrations

• Then New Registration.

• Enter web in the redirect URI and paste the return URL of your GLPI instance:
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29.4.2 Secret and certificate

• In the certificates and secrets tab, create a new secret that will need to be transferred to your Oauth SSO appli-
cation on the GLPI side:

Aviso: When you click on add, the secret will only be available once. As soon as you leave this page, the secret
will be hidden and we will no longer be able to access it. Remember to store it in a safe place as we will need it
later

29.4.3 Claims

Aviso: If you are using SSO V2, an additional step is required. The claims on the Entra side must be entered
manually and should preferably be of type ID.

• In the Token configuration tab

• Click on Add an optional claim

• Add the 4 claims below:
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29.4.4 API authorisations

GLPI must be able to read user information in order to use it for connection - In API permissions - Click on the API
already present (Microsoft Graph for our example)

Select :

• email

• offline_access

• profile

• user.read

• Then remember to save your changes.
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29.4.5 Setup GLPI

• Entra AD provides a description with the essential information you need:

• Specify an application name visible to end users.

Copy the values from the fields above:

• Application ID

• The holder ID

• The value of the secret copied in the previous step

Aviso: Please check that the value of the secret is filled in correctly.If the ID of the secret is copied, your application
will fall into error.
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29.4.6 Explanation of ID field

• 3 values are available in this insert:

1) User Principal Name (UPN): this option will show the full username of the user logging in
(nom.prenom@mondomaine.com for example). If you want only the username to be visible (without the @mon-
domaine.com, see the XXXXXXXXXX paragraph).

2) Entra user ID (OID): this option takes the object ID from the Entra AD. This ID will be used for the user login

3) Email address: This option specifies the user’s email address. This field will be used for the login. If it is empty,
the UPN will be used.

If you need to find your application in the Entra portal, select Application subscriptions, then Display all applications.

29.5 Google

29.5.1 Creating a project

• From your Google console (administrator access is required)

• Go to your organisation then new project

• Enter the name of your project

• Click on Create

• Return to your organisation,

• Select your project
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29.5.2 Setup Oauth access

• From the menu, click on APIs & Services

• Then OAuth consent screen

• Select the type of access that will be granted to the application (internal or external users)

• Then click on Create.

• Enter (as a minimum) a name for the application, an email address for application support and the developer’s
email address (this information is compulsory).

• Click on Save and continue.

• In the Scope section

• Click on Add or remove application fields

• Add auth/userinfo.email auth/userinfo.profile and openid

• Click on Update

• Then Save and continue
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29.5.3 ID settings

• From the Credentials menu

• Click on Create credentials

• Then Oauth client ID.

• Select the type of application Web application

• Enter an application name

• In the Authorized redirect URIs section

• Enter the GLPI Callback URL

Dica: Where can I find my callback URL?

• Click on Create

• A page appears with the identifier values. Keep this information as it will be requested in GLPI.
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29.5.4 Setup GLPI

• From Setup > Oauth SSO applications

• Click on Add

• Select Google in the Oauth provider field

• Select the icon that will be visible on the home page

• Enter the Client ID (number 1 on the previous screenshot)

• Enter the Client secret (numbered 2 on the previous screenshot)

• Enter the field user ID1

• Click on Add

From the home page, the new Oauth SSO login option will be visible:

1 the identifier field will be the user’s login. Google user Id represents the unique value for each user generated when the user is created.
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Nota: The first time a user logs on, they will be asked to accept access authorisations for their profile

29.6 OKTA

29.6.1 Create application

• First, go to GLPI and download the Oauthsso plugin

• Navigate to the Setup > Oauth SSO applications

• Click on Add

• Keep this window active and retain the callback URL :

• In your OKTA interface, go to Applications

• Create App Integration

• Select option OIDC – OpenID Connect in the 1st insert and Web Application in the second

• Click on Next

• Enter an application name and check the box Client credentials

• Enter the return URL, retrieved above, in Sign-in redirect URIs.
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29.6.2 Assignments

• In the last box, select the option that suits you best (here we authorize all users present in OKTA)

• Finally, click on Save

29.6.3 Setup GLPI

• In GLPI, go back to the Oauth SSO plugin configuration window and enter your OKTA tenant information :

1. Give your provider a name, which will appear on the login page.

2. Indicate this as active

3. Enter OKTA as provider Oauth

4. Enter the application ID found in the application previously created in OKTA

1. Specify the ID field to be mapped with OKTA

2. Specify the customer secret available in OKTA in the previously created application

7. Enter the name of your OKTA instance (https://XXXXXXXXX.okta.com), available in the account creation
confirmation e-mail.
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• Click on Add

• In the plugin, you will see the approval message:

Now that the configuration is complete, you can test it with a user.

29.7 Keycloak

29.7.1 Create a REALM

• After installing keycloak, go to the admin console:

http://XXXXXXXXXX:8080/admin or https://XXXXXXXXXX:8080/admin

• Create your realm by clicking on master at the top left of your screen

• Then create Realm

• Give it a name that suits you

• Click on Create

29.7.2 Create user

• Then go to the Users tab

• Then Create new user (we’ll use a local user, but you can synchronize your LDAP if necessary)

• Create your user according to your needs, remembering to check the Email verified box

• Click on Create once you’ve entered your details.

• Stay in your user file and click on Credentials
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• Then Set pasword

• Configure the user password, taking care to indicate that the password is not temporary

• Click on save then Save password

You can check that your configuration is correct by logging on to the user account console:

http://XXXXXXXXXXX/realms/GLPI/account/#/ or https://XXXXXXXXXXX/realms/GLPI/account/#/

(Remember to adapt the realm name if you haven’t named it GLPI).

You will then be able to connect to the record of the previously created user or one of your LDAP users.
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29.7.3 Create client

Now we can register our GLPI application with Keycloak

• Go to Clients

• Create client

• Give your application a client ID, which you’ll need to pass on to your GLPI Oauth SSO configuration

• Click on next and make sure on the next page that the standard flow and client authentication options are active

• Click on Save

Keep this page active, we’ll come back to it later.
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29.7.4 Setup GLPI

• Go to GLPI

• In Setup > Oauth SSO applications click on add (at the top of your screen)

• Start by retrieving the return URL and pasting it into Keycloak’s valid redirect URIs field

• Back in GLPI’s Oauth SSO plugin configuration, fill in the required fields:

1. Give your provider a name, which will appear on the login page for users

2. Activate this plugin so that it is visible and usable on the login page

3. Choose Keycloak as your Oauth provider

4. Enter the client name set above

5. Retrieve client secret from Keycloak (client, client_name, credentials)

6. Enter the discovery URL: http://mondomaine/realms/monrealms/.well-known/openid-configuration.

• Click on Add

In the plugin, to see the approval message:

Now that configuration is complete, you can test the connection with the user you created earlier, or with your LDAP
user.
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29.8 Rules for assigning authorisations

Remember that Oauth SSO authentication allows only authentication, in the sense that no user management is carried
out following authentication.

In most cases, it will therefore be necessary to establish rules for assigning authorisations to your users (to give them
a profile, for example).

• To do this, go to Administration > Rules > Rules for assigning authorisations to a user.

There are no ‘mandatory’ rules, it’s up to you to create the rule(s) that you feel best suit your needs according to your
available criteria.

For example, a very simple rule

• A very simple rule -> I want my users with SSO authentication to obtain the Self-Service profile.

So I set my criteria and my action :
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29.9 Forcing SSO authentication

Using the Oauth SSO application configuration, you can mask the internal database connection field to force the con-
nection with your SSO application

(setup > Oauth SSO applications > setup)

29.10 Resources

• Documentation Oauth SSO client for GLPI

• Documentation Microsoft Configure your App Service Or Entra Functions app to use Entra AD login

• Documentation OKTA Configure single Sign-On options

• Documentation Keycloak Managing OpenID connect Clients
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29.11 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 30

Rename strings

30.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available from the Cloud

30.2 Download the plugin

• Go to Marketplace. Download and install the plugin Rename GLPI strings
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30.3 Creating an override

• Go to Setup > Rename GLPI strings

• Click on Add and select the appropriate language.

• In the Override tab, click on New override.

• Select the value you wish to change from the drop-down list. You can search directly.

We are going to change the value Computer to PC

• Select computer and enter the singular and plural of the word to be changed in the corresponding fields.

• Click on Save

30.4 Show the change

You may not see the change immediately. To make it appear, log out and then log back in.

Before :

After :
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30.5 FAQ

If you have any questions about using the plugin, please consult our FAQ
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SCIM

31.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available from the Cloud.

This plugin let you provision your users and groups from an external identity provider using the SCIM protocol. The
update from the directory to GLPI is done “just in time”. Each modification is done on the fly, without any cron. GLPI
is the service provider, and the directory is the identity provider.

Warning, the SCIM API endpoint provided by the plugin must be accessible from the identity provider. If we
talk about Azure or Okta, this particular url should be available from the internet. We suggest strongly to limit the ip
addresses that can access this url (in addition of adding a strong authentication method).
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31.2 Setup

You must declare an identity server in the plugin configuration (You can add any number). Go to Setup > SCIM
Identity servers menu and click the [+ Add] button on top of the page.

Fill at least:

• The name of the server,

• the user applied on GLPI when receiving a request (this will identify the user in th GLPI logs),

• check the “Active” field,

• and submit by clicking the [+ Add] button at the bottom of the form.

You’ll be given an API url you may paste into your identity provider configuration. Check specific provider documen-
tation for more details.

You may set some optional parameters :

• Save requests in logs: if checked, all requests will be saved in the “Historical” tab of your declared server.

• Default server: if checked, this server will be used by default without providing it’s id in the API Url.

• Security: a dropdown of available security methods. Currently implemented:

– None: no security, anyone can access the API.

– Basic: HTTP Basic authentication. You must provide a username and a password.

– Digest: HTTP Digest authentication. You must provide a username and a password.

– Bearer: HTTP Bearer authentication. A long lived (10years) jwt token will be generated.

– OAuth2: OAuth2 authentication. You must provide at least a valid redirection uri. We support the following
flows:

∗ Authorization code.

∗ Client credentials.

Your SCIM server is now ready to receive requests from your identity provider.
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31.3 Providers

• Azure

• Okta

31.4 A Note about passwords sync

Although it’s mentioned in the SCIM specifications, password sync is not always available depending on the provider:

• Azure: not available

• Okta: available

31.5 FAQ

If you have any questions about using the plugin, please consult our FAQ
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CAPÍTULO 32

Splitcat

32.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available from the Cloud.

32.2 Download the plugin

• From the marketplace (Setup > Plugins), download the Splitcat plugin
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32.3 Settings

There are no special settings to be made for this plugin. You can see the effect of the plugin directly when you open a
new ticket.

32.3.1 Before

32.3.2 After

32.4 FAQ

If you have any questions about using the plugin, please consult our FAQ
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Translate

33.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available from the Cloud.

33.2 Introduction

The Translate plugin for GLPI is a handy tool designed to enhance multilingual communication within your GLPI.
Leveraging DeepL’s translation technology, this plugin provides a simple and effective solution for translating elements
in the ticket timeline, fostering seamless collaboration within international teams.

Whether you’re managing projects with teams scattered worldwide or simply aiming to facilitate communication with
users in different languages, the Translate plugin streamlines the translation process within your GLPI instance.
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33.3 Features

• Translate individual timeline elements

• Translate the entire ticket timeline

• Translate a follow-up during composition

• Restrict translation to specific languages

• Restrict translation to specific types of timeline elements

• API usage notification

• Translation rights management

33.4 Requirements

• GLPI version 10.0.10 or higher

• DeepL API token

33.5 Operation

33.5.1 Translating an Element

Translation of a ticket element is done by activating the translation button located at the top right of the element. The
target language will correspond to the user’s preferred language.

If the translation button does not appear, it may be due to various reasons:

• the plugin is not configured

• you do not have the right to translate

• your preferred language is not allowed in the configuration

• the element you want to translate is not allowed in the configuration
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33.5.2 Undo Translation / Display Original Version

Once an element is translated, it will remain so until you request to undo the translation and display the original version.
Displaying the original version is done through the same button used to translate an element, located at the top right of
the element.

33.5.3 Translate Entire Timeline

It is possible to translate the entire timeline at once. To do this, display the additional options menu at the bottom right,
next to the «Save» button. Then, click on «Translate all elements.»
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33.5.4 Undo Translations / Display Original Versions of Entire Timeline

If all timeline elements are translated and you want to display their original versions, display the additional options
menu at the bottom right, next to the «Save» button. Then, click on «Undo translation of all elements.»
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33.5.5 Translating a Follow-up during Writing

It is possible to translate a follow-up before it is sent. To do this, write your follow-up and click on the drop-down menu
at the top right of the follow-up editing window. Finally, select the language in which the follow-up’s content should
be translated.

Once your follow-up is translated, you can revert to the original text by selecting the «Original» option in the previous
language selection menu.

This feature is also available for tasks, validation requests, and solutions.
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If the translation menu does not appear, it may be due to various reasons:

• the plugin is not configured

• you do not have the right to translate

• the element you want to translate is not allowed in the configuration

33.5.6 Persistence of Translations

To reduce character consumption and improve plugin performance, translations are saved in the database. This approach
allows sharing translations among all users, avoiding the need to translate the same element multiple times in the same
language.

Translation requests from a user for an element are also saved, automatically displaying the translated version when
returning to a ticket’s timeline.

If an element is modified, old translations will be considered obsolete. When a user requests a translation,
a new translation will be performed for that element.
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33.6 DeepL API Key

The Translate plugin uses the DeepL translation service. For this, a DeepL API key is required. DeepL offers two API
plans, a free plan (limited to 500,000 characters per month) and a paid plan (at €4.99/month + €0.00002/character).
Both plans are supported by the plugin.

33.6.1 Obtaining the API Key

1. Visit the DeepL website, «API» section (https://www.deepl.com/pro-api)

2. Select a plan

3. Log in or create an account
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4. Enter your personal informations

5. Accept the terms of use and complete the registration
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6. Click on «Account management» to retrieve your API key

7. In the «Account» tab, retrieve your API key at the bottom of the page, in the «Authentication Key for DeepL
API» section
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33.7 Configuration

33.7.1 Initial Configuration

After installing the plugin, it is necessary to enter a DeepL API key.
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33.7.2 Consumption Configuration

Some configuration options are only available if the API key is linked to the paid plan.

Usage

This progress bar allows you to monitor character consumption at the API level.

Allow Exceeding Limit

Allows setting or not setting a monthly limit on character consumption.

> This option is limited to the paid DeepL API plan.

Usage Limit

Allows setting the type of limitation:

• Characters: Limits usage to the number of characters

• Cost: Limits usage to cost

This option is limited to the paid DeepL API plan.

Per Characters / Per Cost

Allows setting the consumption limit corresponding to the type defined above.

For usage limited by cost, monthly subscription fees are not included.

This option is limited to the paid DeepL API plan.
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Maximum Number of Characters Translated per Translation

Allows setting a maximum number of characters translated at once. This configuration is important and filters out
overly large and resource-consuming elements for the API.

33.7.3 Notification Configuration

Enable API Usage Notifications

Allows enabling API usage notifications. Once enabled, alert thresholds are configurable using the «Usage Threshold»
fields. Default value: Yes

Usage Threshold

This option allows setting usage alert thresholds. Requires enabling the «Enable API Usage Notifications» option.
Default values: 25%, 50%, 75%, 100%

33.7.4 User Configuration

Allowed Target Languages for All Users

Defines the languages in which elements can be translated by all users.
Default values: Languages proposed by DeepL

Allowed Translatable Elements for All Users

Defines the elements that can be translated by all users.
Default values: Ticket, Follow-up, Ticket Task, Solution, Validation Request

33.8 Rights

33.8.1 Allow translation of displayed elements (language configured in preferen-
ces)

This right defines whether a profile can translate timeline elements of a ticket (Ticket, Follow-up, Task, Solution,
Validation Request).
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33.8.2 Allow translation while writing

This right defines whether a profile can translate the content of a follow-up before sending.

33.9 FAQ

If you have any questions about using the plugin, please consult our FAQ
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Unread messages

34.1 Requirements (on-premise)

GLPI Version Minimum PHP Recommended
10.0.x 8.1 8.2

Nota: A basic licence (or higher) is required. This plugin is also available on Cloud.

34.2 Install the plugin

• Go to the marketplace. Download and install the plugin Unread messages.
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34.3 Setting up the plugin

• Go to Administration > Entities, unread messages tab

There are 3 possible settings:

Operation Effect
Disabled The plugin will remain inactive
Per user help-
desk;share
central

Users with the self-service profile will be notified of tickets for which they are the requestor.
Technicians, for their part, will share the notifications. If a notification is read, it will be marked
as read for all other technicians

Per user Each user will have access to their own queue of notifications, including those for their group and
their individual assignments

34.4 Display notifications

34.4.1 Header

When a new activity has not yet been viewed, a bell icon appears:

34.4.2 Listed

Unread messages on a ticket highlight the ticket concerned and a red indicator :

34.4.3 Ticket timeline

New messages will be identified by a banner New messages.
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34.4.4 Management by entity

Management by entity is possible to manage the counting of notifications by entity.

• Go to Administration > Entities, and select the desired entity.

• In the Unread messages tab, select the option that suits you so that unread messages behave differently to the
parent entity.

34.5 FAQ

If you have any questions about using the plugin, please consult our FAQ
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